Sunbird 0.7 RC1 Italian locale displays "Privacy_()" menu item

RESOLVED FIXED

Status

Mozilla Localizations
it / Italian
RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: Danilo Fortunato, Assigned: Mozilla Localizers (Italian))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.8pre) Gecko/20071002

In the Italian version of Sunbird 0.7 RC1 there is a small error in the "Options" menu of the "New Event" dialog".
In this menu we see the item "Privacy_()" instead of "Privacy".

Sunbird 0.7 RC1 English displays the correct label "Privacy".

I contacted the Italian localizer (Iacchi), but he couldn't find a reason for this error. He translated the string correctly (in Italian we don't translate the word "privacy", we actually use the English word).

Any idea ?


Reproducible: Always

Steps to Reproduce:
1. download and install Sunbird 0.7 RC1 Italian
2. create a new event
3. in the "New Event" dialog, click on "Options" menu
Actual Results:  
We see the menu item "Privacy_()".

Expected Results:  
We should see the menu item "Privacy".

Comment 1

11 years ago
Usually the () note the access key if not contained in the word before. The access key is defined in http://lxr.mozilla.org/l10n-mozilla1.8/source/it/calendar/chrome/prototypes/sun-calendar-event-dialog.dtd#104

103 <!ENTITY event.menu.options.privacy.label "Privacy">
104 <!ENTITY event.menu.options.privacy.accesskey " v">

Seems that the menu handling assumes that the access key is " " and marks the blank between Privacy and () with the underscore. Changing the entity from " v" to "v" will probably solve it.
Assignee: nobody → l10n-it
Blocks: 396938
Component: General → it-IT / Italian
Product: Calendar → Mozilla Localizations
QA Contact: general → prometeo.bugs

Comment 2

11 years ago
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.0; it; rv:1.8.1.8pre) Gecko/20071014 Sunbird/0.7
Status: UNCONFIRMED → NEW
Ever confirmed: true
Fixed on cvs, on tag SUNBIRD_0_7_BRANCH. Should I commit it even on MOZILLA_1_8_BRANCH to see this fix applied to Sunbird 0.7?

Comment 4

11 years ago
Please commit all your changes to the MOZILLA_1_8_BRANCH and the trunk as well.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
I know, but since with TortoiseCVS I still haven't found a fast method to do it (commit to more than one tag), I want to know if I need to commit to SUNBIRD_0_7_BRANCH only for sunbird 0.7, and update the other tags when I have enough time, or if i have to commit changes to MOZILLA_1_8_BRANCH as well.
You need to log in before you can comment on or make changes to this bug.