Closed Bug 399927 Opened 13 years ago Closed 13 years ago

Can't log in until cookies are cleared

Categories

(support.mozilla.org :: Knowledge Base Software, task)

task
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jason.barnabe, Assigned: morgamic)

References

Details

(Whiteboard: tiki_test)

Sometimes, I can't log in to sumo. Entering my log in info and pressing "login", I just go back to the same page.

I noticed looking at my cookies I have a PHPSESSID cookie for the path "/" and one for the path "/kb". Once I delete the kb one, I can log in.
The /kb cookie is dropped if the first time you go to the site is to a /kb/... location. After that, when you try to login, you will pick up a different cookie for "/". You will then not be able to login. If you go first to support.mozilla.com, things are ok.

I will have a look at it.
Duplicate of this bug: 400058
We really want this to be fixed by 0.1. Nelson, possible?
Target Milestone: --- → 0.1
Yes. The fix itself is simple. However, have to coordinate with all the other changes, e.g. upgrade and so on, going on at the same time.
Assignee: nobody → morgamic
morgamic: Line 243 tiki-setup_base is not needed for our case I think. Can you roll that into the changes you are making?
Given that this is not being taken care of quickly, I presume some people have a work-around. What is the work-around?
Delete the SESSION_ID cookie that has a path of /kb .
You can also make it a point to first go to support.mozilla.com before going to any other page each time you visit.
Erg. Ok. I can log in. The page shows I am logged in. Then I go to another page and I see "Contributor Login" link. Re-log in. Go to another page. I am not logged in.

I know you guys had your reason, but I have _never_ had this kind of crap happen with MediaWiki.....
(In reply to comment #9)
> Erg. Ok. I can log in. The page shows I am logged in. Then I go to another page
> and I see "Contributor Login" link. Re-log in. Go to another page. I am not
> logged in.

The Contributor Login link is always there whether you're logged in or not. Bug 401713.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Duplicate of this bug: 400058
Whiteboard: tiki_triage
Whiteboard: tiki_triage → tiki_test
You need to log in before you can comment on or make changes to this bug.