add rss feed does not populate live bookmark if the feed was previously deleted

VERIFIED DUPLICATE of bug 388716

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 388716
10 years ago
8 years ago

People

(Reporter: abillings, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
Using today's trunk, when I go to http://del.icio.us/rss/ and add the feed as a live bookmark to the toolbar, the feed contents do not populate. If the feed is deleted and re-added, *sometimes* it will then work. If the user does a manual reload on the feed, it normally works.

Tracy Walker and I both tried this several times, purging data and restarting. 

This is also seen on http://del.icio.us/rss/recent?min=2 and http://rss.news.yahoo.com/rss/mostemailed. There seems to be a general issue here.
(Reporter)

Comment 1

10 years ago
This was in build  Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007101604 Minefield/3.0a9pre.

Comment 2

10 years ago
Let me clarify this bug:

STR:

1) visit del.icio.us
2) Subscribe the feed and add it to the Bookmarks toolbar folder
notice the Live Bookmark "del.icio.us hotlist" has 10 items
3) Delete the Live Bookmark for "del.icio.us hotlist"
4 re-subscribe and add the same feed back to the bookmarks toolbar.

tested results:
The Live Bookmark for "del.icio.us hotlist" is "(Empty)

expected results:
The Live Bookmark for "del.icio.us hotlist" has a list of 10 items just as it did the first time it was added.

This is a regression from the 2.0.0.x branch that happens on all platforms.
Keywords: regression
OS: Mac OS X → All
Hardware: Macintosh → All
Summary: del.icio.us rss feed does not populate live bookmark → add rss feed does not populate live bookmark if the feed was previously deleted
(Reporter)

Comment 3

10 years ago
Except that on my clean profile, in your steps above, the feed does not show any content in the live bookmark the FIRST time I add it. I get the result you show immediately.
Comment 2 is (near as I can tell without actually successfully debugging it) bug 388716; comment 0 I can't seem to reproduce.

Comment 5

10 years ago
yes, what I described, is in all likely hood, bug 388716.

Al, I can't reproduce the failure you're describing.

Comment 6

10 years ago
should be fixed in 388716, since it's the same problem
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 388716

Comment 7

10 years ago
(In reply to comment #3)
> Except that on my clean profile, in your steps above, the feed does not show
> any content in the live bookmark the FIRST time I add it. I get the result you
> show immediately.


this is because of the expire annotation, still should be fixed there

(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.