Firefox 2 will not compile on Mac OS X 10.5 in common configurations

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Josh Aas, Assigned: Josh Aas)

Tracking

({fixed1.8.1.10})

1.8 Branch
x86
Mac OS X
fixed1.8.1.10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

10 years ago
Firefox 2 will not compile with the native 10.5 SDK and tests turned on. You have to use the 10.4 SDK and turn tests off.
(Assignee)

Comment 1

10 years ago
Created attachment 285244 [details] [diff] [review]
fix MFX v1.0

We can fix this bug in pieces. Here is part 1, MoreFilesX. FSVolumeMount exists on 10.5, we can't redefine it in MFX.
Assignee: nobody → joshmoz
Status: NEW → ASSIGNED
Attachment #285244 - Flags: review?(mark)
(Assignee)

Updated

10 years ago
Version: unspecified → 1.8 Branch

Comment 2

10 years ago
Comment on attachment 285244 [details] [diff] [review]
fix MFX v1.0

>-	const void *volMountInfo,
>+    const void *volMountInfo,
> 	FSVolumeRefNum *volRefNum);

This file uses tabs, so just leave the tab as-is to ensure that the parameters line up properly.
Attachment #285244 - Flags: review?(mark) → review+
(Assignee)

Comment 3

10 years ago
Created attachment 285261 [details] [diff] [review]
pthread_kill fix v1.0
Attachment #285261 - Flags: review?(mark)
(Assignee)

Updated

10 years ago
Attachment #285244 - Flags: superreview?(benjamin)
(Assignee)

Comment 4

10 years ago
Created attachment 285274 [details] [diff] [review]
trunk MFX fix v1.0
Attachment #285261 - Attachment is obsolete: true
Attachment #285274 - Flags: superreview?(benjamin)
Attachment #285261 - Flags: review?(mark)
(Assignee)

Comment 5

10 years ago
We should just land the MFX part of this, syncing trunk, and require users to use the 10.4 SDK. Getting the 1.8 branch working correctly with the 10.5 SDK is going to be a huge pain.

Comment 6

10 years ago
Note: 1.8 stuff will still be buildable on Leopard as long as the 10.4u (or lower) SDK is selected.  This is fine.
(Assignee)

Updated

10 years ago
Attachment #285274 - Flags: approval1.9?
(Assignee)

Comment 7

10 years ago
Created attachment 285742 [details] [diff] [review]
fix tests with 10.4u SDK, v1.0

You can't build with the 10.4u SDK if you have tests enabled.

In file included from mozilla/dbm/tests/lots.c:66:
/Developer/SDKs/MacOSX10.4u.sdk/usr/lib/gcc/i686-apple-darwin9/4.0.1/include/varargs.h:4:2: error: #error "GCC no longer implements <varargs.h>."
/Developer/SDKs/MacOSX10.4u.sdk/usr/lib/gcc/i686-apple-darwin9/4.0.1/include/varargs.h:5:2: error: #error "Revise your code to use <stdarg.h>."
mozilla/dbm/tests/lots.c:108:18: error: macro "va_start" requires 2 arguments, but only 1 given

And so on. I think we just need to define STDC_HEADERS and we will be fine, but I can't test this at the moment because autoconf213 package is broken on 10.5.
Attachment #285742 - Flags: review?(mark)

Comment 8

10 years ago
Comment on attachment 285742 [details] [diff] [review]
fix tests with 10.4u SDK, v1.0

This sounds fine to me, but I don't think it's a 1.8-only problem, the same thing seems to exist on the trunk.
Attachment #285742 - Flags: review?(mark) → review+
(Assignee)

Updated

10 years ago
Attachment #285742 - Flags: superreview?(roc)
Attachment #285742 - Flags: superreview?(roc) → superreview+
(Assignee)

Updated

10 years ago
Attachment #285742 - Flags: approval1.8.1.9?
Attachment #285742 - Flags: approval1.8.1.9? → approval1.8.1.10?
Attachment #285244 - Flags: superreview?(benjamin) → superreview+
Attachment #285274 - Flags: superreview?(benjamin) → superreview+
(Assignee)

Updated

10 years ago
Attachment #285244 - Flags: approval1.8.1.10?
(Assignee)

Updated

10 years ago
Duplicate of this bug: 401598

Comment 10

10 years ago
MacPorts' autoconf213 works on 10.5 for me now.

See also bug 401768 for more (different) 10.5 build problems on the 1.8 branch.

Comment 11

10 years ago
Comment on attachment 285261 [details] [diff] [review]
pthread_kill fix v1.0

See bug 401813 for an alternative to this (obsolete) patch.
Comment on attachment 285244 [details] [diff] [review]
fix MFX v1.0

approved for 1.8.1.10, a=dveditz for release-drivers
Attachment #285244 - Flags: approval1.8.1.10? → approval1.8.1.10+
Attachment #285742 - Flags: approval1.8.1.10? → approval1.8.1.10+
(Assignee)

Comment 13

10 years ago
tests fix landed on 1.8 branch, waiting to land trunk patch to mark this bug fixed

Comment 14

10 years ago
Josh, are you waiting to land the trunk MFX patch to land the MFX 1.8 branch patch too?
(Assignee)

Comment 15

10 years ago
No, I didn't notice that it got approved. I'll land it asap. Thanks for pointing that out.
(Assignee)

Comment 16

10 years ago
checked in "fix MFX v1.0" with tab comment addressed on MOZILLA_1_8_BRANCH

leaving this open for the trunk version of that fix

Updated

10 years ago
Attachment #285274 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 17

10 years ago
trunk sync fix landed
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.1.10
Josh, can you verify that the issue is fixed in *both* branch and trunk, please?
You need to log in before you can comment on or make changes to this bug.