password manager files have Unix line endings on Windows

RESOLVED FIXED

Status

SeaMonkey
Passwords & Permissions
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Assigned: dveditz)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

When SeaMonkey recently changed to be "SuiteRunner", and be more like
FireFox, lots of text files in SeaMonkey's profile directory changed.
They formerly had Windows style line endings, each line ending with CR LF.
Now they have Unix style line endings, with lines ending only with LF.

This makes them look bad when displayed, and makes them uneditable in 
Windows text editors, because the code cannot read the files after the
line endings have been converted to Windows style.

Among the many file affected by this are the password manager files, 
NNNNNN.s and NNNNNN.w
(Reporter)

Updated

11 years ago
Keywords: regression
This should become fixed as a side effect of bug 390025, whenever that happens. Login Manager's signons2.txt has the right line endings.
(Reporter)

Updated

11 years ago
Summary: password maanger files have Unix line endings on Windows → password manager files have Unix line endings on Windows

Comment 2

10 years ago
Fixed by Bug 390025 (Move to LoginManager and remove wallet from SeaMonkey)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Depends on: 390025
You need to log in before you can comment on or make changes to this bug.