The default bug view has changed. See this FAQ.

New composer window isn't unmodified

RESOLVED FIXED

Status

SeaMonkey
Composer
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey1.1.7, fixed-seamonkey1.1.8, regression})

Trunk
fixed-seamonkey1.1.7, fixed-seamonkey1.1.8, regression
Bug Flags:
blocking-seamonkey1.1.8 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
Steps to reproduce problem:
1. Open a new composer page
2. Close it

Expected result: page closes

Actual result: save page dialog

This is because SetDocumentCharacterSet increments the modification count.
Flags: blocking-seamonkey1.1.6?

Comment 1

10 years ago
I am assuming this regression is on branch as well as trunk?
Flags: blocking-seamonkey1.1.6? → blocking-seamonkey1.1.6+
(Assignee)

Comment 2

10 years ago
Created attachment 286488 [details] [diff] [review]
Proposed patch

I assume here that setting the charset is normally supposed to be undoable...
Assignee: composer → neil
Status: NEW → ASSIGNED
Attachment #286488 - Flags: review?(daniel)
Comment on attachment 286488 [details] [diff] [review]
Proposed patch

r=me
Attachment #286488 - Flags: review?(daniel) → review+
(Assignee)

Updated

10 years ago
Attachment #286488 - Flags: approval-seamonkey1.1.6?

Updated

10 years ago
Attachment #286488 - Flags: approval-seamonkey1.1.6? → approval-seamonkey1.1.6+
(Assignee)

Comment 4

10 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed-seamonkey1.1.6
Resolution: --- → FIXED

Updated

7 years ago
Keywords: fixed-seamonkey1.1.8
You need to log in before you can comment on or make changes to this bug.