Float containing/clearing problem when a float has a negative margin in Firefox 2.0.0.8

VERIFIED DUPLICATE of bug 400406

Status

()

--
major
VERIFIED DUPLICATE of bug 400406
11 years ago
11 years ago

People

(Reporter: office, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

In the latest Firefox version, the browser seems to have a problem containing and/or clearing a float, that has a negative margin. This is a big problem because a lot of recent CSS layout use this technique to create source ordered multicolumn layouts. 

Reproducible: Always

Steps to Reproduce:
1. create two floats (float:left)
2. change order by adding a positive margin to the first and a negative margin to the second one
3. wrap both floats with another float. This wrapper should contain both inner floats.
4. place any element with property (clear:both) below this wrapper.
Actual Results:  
The wrapper DIV fails to contain the float that has the negative margin. The element below the wrapper fails to clear the float.

Expected Results:  
The wrapper DIV should contain both inner floats. Even if not (because of any bug) the element with clear property below the wrapper should clear the float.

I've made a testcase. See the URL.

This bug showed up with Firefox 2.0.0.8 and could cause huge problems on modern CSS based layouts with source ordered multicolumn designs.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400406
Regression range: 2007-10-03-03 -- 2007-10-04-03
Status: RESOLVED → VERIFIED
Can confirm this using Gecko/20071009 WinXP and Linux official 2.0.0.8.
Current trunk works as expected so this is branch only.

Must have been happened after 20071002 nightly before 20071003 nightlies.
Time-window therefore is: http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=MOZILLA_1_8_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-10-02&maxdate=2007-10-04&cvsroot=%2Fcvsroot

I tested and cannot reproduce after backing out bug #387201. So that seems to be the cause.
Ever confirmed: true
Flags: blocking1.8.1.9?
Keywords: regression
Flags: blocking1.8.1.9?
(Reporter)

Comment 4

11 years ago
I only could test with Windows Vista but in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=400406">bug 400406</a> report, all OS-Systems are mentioned. 

And there are more reports of broken layouts out there ...
http://www.stefan-niggemeier.de/blog/firefox-2008-frisst-blog-design/
(Reporter)

Comment 5

11 years ago
Created attachment 285592 [details]
Testcase for float containing/clearing bug
(Reporter)

Comment 6

11 years ago
Info from an email: Mozilla 1.7.12 seems to has this bug too.
I don't think replying this bug will help, was it was marked duplicate #400406 (which I missed, sorry).
Dirk, you better reply to #400406. ;)
You need to log in before you can comment on or make changes to this bug.