Last Comment Bug 400618 - Crash [@ js_AllocStack] pageads/adsense test cases req. Firebug 1.1 install
: Crash [@ js_AllocStack] pageads/adsense test cases req. Firebug 1.1 install
Status: RESOLVED DUPLICATE of bug 237823
[firebug-want]
: crash, testcase, topcrash
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 2.0 Branch
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://talkback-public.mozilla.org/ta...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 12:29 PDT by John J. Barton
Modified: 2011-06-13 10:01 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test procedure and links to crashing pages. (4.10 KB, text/html)
2007-10-21 12:30 PDT, John J. Barton
no flags Details

Description John J. Barton 2007-10-21 12:29:11 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

In testing a workaround for bug 400532 I discovered that my test cases reproducibly crashed another way.  Well to be honest the reproducibility is weak, and my bet is that other machines will cause these cases to crash in other ways.

Reproducible: Always

Steps to Reproduce:
See attached HTML, need to install firebug-1.1.0b6
1.about:config javascript.options.strict true
2.Start with http://tutorials.zen-cart.com
3.
Actual Results:  
TB 37197755, 37197905
Comment 1 John J. Barton 2007-10-21 12:30:22 PDT
Created attachment 285672 [details]
Test procedure and links to crashing pages.
Comment 2 John J. Barton 2007-10-21 12:31:36 PDT
Here is the trace from TB
js_AllocStack  [mozilla/js/src/jsinterp.c, line 396]
nsXPCWrappedJSClass::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1210]
nsXPCWrappedJS::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 468]
SharedStub  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
nsEventListenerManager::HandleEventSubType  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1655]
nsEventListenerManager::HandleEvent  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1762]
nsGlobalWindow::HandleDOMEvent  [mozilla/dom/src/base/nsGlobalWindow.cpp, line 1733]
nsDocument::HandleDOMEvent  [mozilla/content/base/src/nsDocument.cpp, line 4085]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2188]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2182]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2182]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2182]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2182]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2182]
nsEventStateManager::DispatchMouseEvent  [mozilla/content/events/src/nsEventStateManager.cpp, line 2797]
nsEventStateManager::NotifyMouseOver  [mozilla/content/events/src/nsEventStateManager.cpp, line 2922]
nsEventStateManager::GenerateMouseEnterExit  [mozilla/content/events/src/nsEventStateManager.cpp, line 2954]
nsEventStateManager::PreHandleEvent  [mozilla/content/events/src/nsEventStateManager.cpp, line 567]
PresShell::HandleEventInternal  [mozilla/layout/base/nsPresShell.cpp, line 6468]
PresShell::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 6310]
nsViewManager::HandleEvent  [mozilla/view/src/nsViewManager.cpp, line 2566]
nsViewManager::DispatchEvent  [mozilla/view/src/nsViewManager.cpp, line 2253]
HandleEvent  [mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1319]
nsWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6329]
ChildWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6576]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1507]
USER32.dll + 0x8734 (0x7e418734)
USER32.dll + 0x8816 (0x7e418816)
USER32.dll + 0x89cd (0x7e4189cd)
USER32.dll + 0x8a10 (0x7e418a10)
nsAppShell::Run  [mozilla/widget/src/windows/nsAppShell.cpp, line 159]
nsAppStartup::Run  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
main  [mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x16fd7 (0x7c816fd7)
Comment 3 John J. Barton 2007-10-21 12:35:07 PDT
Search TB for URL="FunctionSourceCrashTests" to see all of the traces from these cases. the msvcrt ones are from bug 400532.
Comment 4 John J. Barton 2007-10-23 09:06:28 PDT
The version of Firebug I used for these tests is now available:
http://fireclipse.xucia.com/files/fireclipse/firebug-1.1.0b6.xpi
Comment 5 Samuel Sidler (old account; do not CC) 2007-11-04 16:15:05 PST
This looks like a topcrash as well. I'll look into this more this week.
Comment 6 timeless 2007-12-25 09:40:33 PST

*** This bug has been marked as a duplicate of bug 320256 ***
Comment 7 timeless 2007-12-26 06:47:49 PST
oops, you're right, let's pick the closer call stack which does relate to jsd :)

*** This bug has been marked as a duplicate of bug 237823 ***
Comment 8 Anthony Ettinger 2008-01-30 03:17:14 PST
100% reproducable:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

1) of course, make sure firebug is installed and active (can still be 'disabled' for mail.google.com and still crash)
2) login to gmail via https (ssl): https://mail.google.com/mail/
3) make sure your gmail account is the first tab (it loads automatically for me as my homepage when I start firefox)
4) click the first checkbox next to the first message, shift scroll down, click another checkbox (mass selection of emails here)...at this point the "beach ball" usually starts to spin on MacOSX (tiger).
5) wait a few seconds, simply close tab => CRASH ....works everytime for me.
6) This happens on google.com/reader as well
Comment 9 John J. Barton 2008-01-30 08:34:12 PST
(In reply to comment #8)
> 100% reproducable:
> 
Hi Anthony, just to check that this problem is the same one we discuss here, do you have the traceback for this crash?  John.
Comment 10 Anthony Ettinger 2008-01-30 10:46:43 PST
Date/Time:      2008-01-30 10:42:59.067 -0800
OS Version:     10.4.11 (Build 8S2167)
Report Version: 4

Command: firefox-bin
Path:    /Applications/Firefox.app/Contents/MacOS/firefox-bin
Parent:  WindowServer [56]

Version: 2.0.0.11 (2.0.0.11)

PID:    229
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x3765a0ff

Thread 0 Crashed:
0   libjsd.dylib                   	0x01af2b65 NSGetModule + 15121
1   libxpcom_core.dylib            	0x00e5a8d9 XPTC_InvokeByIndex + 81
2   org.mozilla.firefox            	0x00370ee7 XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) + 743
3   org.mozilla.firefox            	0x00363187 XPC_WN_CallMethod(JSContext*, JSObject*, unsigned, long*, long*) + 261
4   libmozjs.dylib                 	0x00c5a65f js_Invoke + 858
5   libmozjs.dylib                 	0x00c4cde9 js_Interpret + 4632
6   libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
7   org.mozilla.firefox            	0x005c1e22 nsXPCWrappedJSClass::CheckForException(XPCCallContext&, char const*, char const*) + 2454
8   org.mozilla.firefox            	0x005bf01b nsXPCWrappedJS::SystemIsBeingShutDown(JSRuntime*) + 483
9   libxpcom_core.dylib            	0x00e5a992 XPTC_InvokeByIndex + 266
10  libxpcom_core.dylib            	0x00e5abde nsXPTCStubBase::Stub8() + 40
11  libxpcom_core.dylib            	0x00e5a8d9 XPTC_InvokeByIndex + 81
12  org.mozilla.firefox            	0x00370ee7 XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) + 743
13  org.mozilla.firefox            	0x00363187 XPC_WN_CallMethod(JSContext*, JSObject*, unsigned, long*, long*) + 261
14  libmozjs.dylib                 	0x00c5a65f js_Invoke + 858
15  libmozjs.dylib                 	0x00c4cde9 js_Interpret + 4632
16  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
17  libmozjs.dylib                 	0x00c4603e js_fun_toString + 1789
18  libmozjs.dylib                 	0x00c5a65f js_Invoke + 858
19  libmozjs.dylib                 	0x00c4cde9 js_Interpret + 4632
20  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
21  org.mozilla.firefox            	0x005c1e22 nsXPCWrappedJSClass::CheckForException(XPCCallContext&, char const*, char const*) + 2454
22  org.mozilla.firefox            	0x005bf01b nsXPCWrappedJS::SystemIsBeingShutDown(JSRuntime*) + 483
23  libxpcom_core.dylib            	0x00e5a992 XPTC_InvokeByIndex + 266
24  libxpcom_core.dylib            	0x00e5aae4 nsXPTCStubBase::Stub3() + 40
25  libxpcom_core.dylib            	0x00e5a8d9 XPTC_InvokeByIndex + 81
26  org.mozilla.firefox            	0x00370ee7 XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) + 743
27  org.mozilla.firefox            	0x00363187 XPC_WN_CallMethod(JSContext*, JSObject*, unsigned, long*, long*) + 261
28  libmozjs.dylib                 	0x00c5a65f js_Invoke + 858
29  libmozjs.dylib                 	0x00c4603e js_fun_toString + 1789
30  libmozjs.dylib                 	0x00c5a65f js_Invoke + 858
31  libmozjs.dylib                 	0x00c4cde9 js_Interpret + 4632
32  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
33  org.mozilla.firefox            	0x005c1e22 nsXPCWrappedJSClass::CheckForException(XPCCallContext&, char const*, char const*) + 2454
34  org.mozilla.firefox            	0x005bf01b nsXPCWrappedJS::SystemIsBeingShutDown(JSRuntime*) + 483
35  libxpcom_core.dylib            	0x00e5a992 XPTC_InvokeByIndex + 266
36  libxpcom_core.dylib            	0x00e5ab48 nsXPTCStubBase::Stub5() + 40
37  libxpcom_core.dylib            	0x00e5a8d9 XPTC_InvokeByIndex + 81
38  org.mozilla.firefox            	0x00370ee7 XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) + 743
39  org.mozilla.firefox            	0x00363187 XPC_WN_CallMethod(JSContext*, JSObject*, unsigned, long*, long*) + 261
40  libmozjs.dylib                 	0x00c5a65f js_Invoke + 858
41  libmozjs.dylib                 	0x00c4cde9 js_Interpret + 4632
42  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
43  libmozjs.dylib                 	0x00c5b4e6 js_InternalInvoke + 146
44  libmozjs.dylib                 	0x00c20311 JS_CallFunctionValue + 62
45  org.mozilla.firefox            	0x00501296 nsJSContext::CallEventHandler(JSObject*, JSObject*, unsigned, long*, long*) + 430
46  org.mozilla.firefox            	0x004e3805 nsJSEventListener::~nsJSEventListener [in-charge]() + 831
47  org.mozilla.firefox            	0x0018ebe8 nsEventListenerManager::HandleEventSubType(nsListenerStruct*, nsIDOMEventListener*, nsIDOMEvent*, nsIDOMEventTarget*, unsigned, unsigned) + 186
48  org.mozilla.firefox            	0x0018fd16 nsEventListenerManager::FixContextMenuEvent(nsPresContext*, nsIDOMEventTarget*, nsEvent*, nsIDOMEvent**) + 1596
49  org.mozilla.firefox            	0x0047b2c2 nsXULElement::HandleDOMEvent(nsPresContext*, nsEvent*, nsIDOMEvent**, unsigned, nsEventStatus*) + 1872
50  org.mozilla.firefox            	0x0047ad91 nsXULElement::HandleDOMEvent(nsPresContext*, nsEvent*, nsIDOMEvent**, unsigned, nsEventStatus*) + 543
51  org.mozilla.firefox            	0x00430258 nsEventStateManager::DoScrollText(nsPresContext*, nsIFrame*, nsInputEvent*, int, int, nsEventStateManager::ScrollQuantity) + 2468
52  org.mozilla.firefox            	0x0018eee7 nsEventListenerManager::HandleEventSubType(nsListenerStruct*, nsIDOMEventListener*, nsIDOMEvent*, nsIDOMEventTarget*, unsigned, unsigned) + 953
53  org.mozilla.firefox            	0x004c14bb nsDOMEventRTTearoff::GetEventReceiver(nsIDOMEventReceiver**) + 171
54  libxpcom_core.dylib            	0x00e5a8d9 XPTC_InvokeByIndex + 81
55  org.mozilla.firefox            	0x00370ee7 XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) + 743
56  org.mozilla.firefox            	0x00363187 XPC_WN_CallMethod(JSContext*, JSObject*, unsigned, long*, long*) + 261
57  libmozjs.dylib                 	0x00c5a65f js_Invoke + 858
58  libmozjs.dylib                 	0x00c4cde9 js_Interpret + 4632
59  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
60  libmozjs.dylib                 	0x00c5b4e6 js_InternalInvoke + 146
61  libmozjs.dylib                 	0x00c5b603 js_InternalGetOrSet + 102
62  libmozjs.dylib                 	0x00c67b1e js_SetProperty + 1578
63  libmozjs.dylib                 	0x00c56676 js_Interpret + 43685
64  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
65  libmozjs.dylib                 	0x00c5b4e6 js_InternalInvoke + 146
66  libmozjs.dylib                 	0x00c5b603 js_InternalGetOrSet + 102
67  libmozjs.dylib                 	0x00c67b1e js_SetProperty + 1578
68  libmozjs.dylib                 	0x00c56676 js_Interpret + 43685
69  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
70  libmozjs.dylib                 	0x00c5b4e6 js_InternalInvoke + 146
71  libmozjs.dylib                 	0x00c5b603 js_InternalGetOrSet + 102
72  libmozjs.dylib                 	0x00c67b1e js_SetProperty + 1578
73  libmozjs.dylib                 	0x00c56676 js_Interpret + 43685
74  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
75  libmozjs.dylib                 	0x00c5b4e6 js_InternalInvoke + 146
76  libmozjs.dylib                 	0x00c5b603 js_InternalGetOrSet + 102
77  libmozjs.dylib                 	0x00c67b1e js_SetProperty + 1578
78  libmozjs.dylib                 	0x00c56676 js_Interpret + 43685
79  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
80  libmozjs.dylib                 	0x00c5b4e6 js_InternalInvoke + 146
81  libmozjs.dylib                 	0x00c5b603 js_InternalGetOrSet + 102
82  libmozjs.dylib                 	0x00c67b1e js_SetProperty + 1578
83  libmozjs.dylib                 	0x00c56676 js_Interpret + 43685
84  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
85  libmozjs.dylib                 	0x00c5b4e6 js_InternalInvoke + 146
86  libmozjs.dylib                 	0x00c5b603 js_InternalGetOrSet + 102
87  libmozjs.dylib                 	0x00c67b1e js_SetProperty + 1578
88  libmozjs.dylib                 	0x00c56676 js_Interpret + 43685
89  libmozjs.dylib                 	0x00c5ae06 js_Invoke + 2817
90  libmozjs.dylib                 	0x00c5b4e6 js_InternalInvoke + 146
91  libmozjs.dylib                 	0x00c20311 JS_CallFunctionValue + 62
92  org.mozilla.firefox            	0x00501296 nsJSContext::CallEventHandler(JSObject*, JSObject*, unsigned, long*, long*) + 430
93  org.mozilla.firefox            	0x0040b636 nsGlobalWindow::RunTimeout(nsTimeout*) + 1510
94  org.mozilla.firefox            	0x0040b6b2 nsGlobalWindow::TimerCallback(nsITimer*, void*) + 32
95  libxpcom_core.dylib            	0x00e47781 nsTimerImpl::Fire() + 187
96  libxpcom_core.dylib            	0x00e47f53 handleTimerEvent(TimerEventType*) + 107
97  libxpcom_core.dylib            	0x00e44551 PL_HandleEvent + 21
98  libxpcom_core.dylib            	0x00e4480a PL_ProcessPendingEvents + 103
99  com.apple.CoreFoundation       	0x9082cf1a CFRunLoopRunSpecific + 1213
100 com.apple.CoreFoundation       	0x9082ca56 CFRunLoopRunInMode + 61
101 com.apple.HIToolbox            	0x92df0878 RunCurrentEventLoopInMode + 285
102 com.apple.HIToolbox            	0x92deff82 ReceiveNextEventCommon + 385
103 com.apple.HIToolbox            	0x92e38a74 _AcquireNextEvent + 58
104 com.apple.HIToolbox            	0x92e388bc RunApplicationEventLoop + 150
105 org.mozilla.firefox            	0x00235c13 nsAppShell::~nsAppShell [in-charge deleting]() + 133
106 org.mozilla.firefox            	0x002c1832 nsAppStartup::DestroyExitEvent(PLEvent*) + 148
107 org.mozilla.firefox            	0x0000606e XRE_main + 5892
108 org.mozilla.firefox            	0x00002c78 main + 32
109 org.mozilla.firefox            	0x00002bfe start + 270
110 org.mozilla.firefox            	0x00002b19 start + 41

Thread 1:
0   libSystem.B.dylib              	0x9001a1cc select + 12
1   libnspr4.dylib                 	0x00ed99bc PR_Poll + 134
2   org.mozilla.firefox            	0x0033cfc3 nsSocketTransportService::Poll(unsigned*) + 99
3   org.mozilla.firefox            	0x0033d5a1 nsSocketTransportService::ServiceEventQ() + 623
4   libxpcom_core.dylib            	0x00e46fe3 nsThread::Main(void*) + 41
5   libnspr4.dylib                 	0x00edaffd PR_Select + 813
6   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 2:
0   libSystem.B.dylib              	0x90047dd7 semaphore_timedwait_signal_trap + 7
1   libnspr4.dylib                 	0x00ed6694 PR_Lock + 246
2   libnspr4.dylib                 	0x00ed69eb PR_WaitCondVar + 75
3   libxpcom_core.dylib            	0x00e492fc TimerThread::Shutdown() + 284
4   libxpcom_core.dylib            	0x00e46fe3 nsThread::Main(void*) + 41
5   libnspr4.dylib                 	0x00edaffd PR_Select + 813
6   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 3:
0   libSystem.B.dylib              	0x900248c7 semaphore_wait_signal_trap + 7
1   libnspr4.dylib                 	0x00ed6a75 PR_WaitCondVar + 213
2   org.mozilla.firefox            	0x0035033c nsSSLThread::Run() + 162
3   libnspr4.dylib                 	0x00edaffd PR_Select + 813
4   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 4:
0   libSystem.B.dylib              	0x900248c7 semaphore_wait_signal_trap + 7
1   libnspr4.dylib                 	0x00ed6a75 PR_WaitCondVar + 213
2   org.mozilla.firefox            	0x0034cf71 nsCertVerificationThread::Run() + 239
3   libnspr4.dylib                 	0x00edaffd PR_Select + 813
4   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 5:
0   libSystem.B.dylib              	0x900248c7 semaphore_wait_signal_trap + 7
1   libnspr4.dylib                 	0x00ed6a75 PR_WaitCondVar + 213
2   org.mozilla.firefox            	0x00525414 mozStorageService::FinishAsyncIO() + 284
3   org.mozilla.firefox            	0x00866560 nsPluginNativeWindow::~nsPluginNativeWindow [in-charge deleting]() + 424
4   libxpcom_core.dylib            	0x00e46fe3 nsThread::Main(void*) + 41
5   libnspr4.dylib                 	0x00edaffd PR_Select + 813
6   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 6:
0   libSystem.B.dylib              	0x900248c7 semaphore_wait_signal_trap + 7
1   libnspr4.dylib                 	0x00ed6a75 PR_WaitCondVar + 213
2   libnspr4.dylib                 	0x00ed6cd5 PR_Wait + 53
3   libxpcom_core.dylib            	0x00e4466e PL_WaitForEvent + 62
4   libxpcom_core.dylib            	0x00e45939 nsEventQueueImpl::CheckForDeactivation() + 149
5   org.mozilla.firefox            	0x002e7215 nsUrlClassifierDBServiceWorker::~nsUrlClassifierDBServiceWorker [in-charge]() + 345
6   libnspr4.dylib                 	0x00edaffd PR_Select + 813
7   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 7:
0   libSystem.B.dylib              	0x90026d5c kevent + 12
1   ...ple.CoreServices.CarbonCore 	0x90cb8c68 PrivateMPEntryPoint + 51
2   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 8:
0   libSystem.B.dylib              	0x900248c7 semaphore_wait_signal_trap + 7
1   ...ple.CoreServices.CarbonCore 	0x90cb8e0d MPWaitOnQueue + 198
2   com.apple.DesktopServices      	0x9271e943 TNodeSyncTask::SyncTaskProc(void*) + 143
3   ...ple.CoreServices.CarbonCore 	0x90cb8c68 PrivateMPEntryPoint + 51
4   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 9:
0   libSystem.B.dylib              	0x90047dd7 semaphore_timedwait_signal_trap + 7
1   libnspr4.dylib                 	0x00ed6694 PR_Lock + 246
2   libnspr4.dylib                 	0x00ed69eb PR_WaitCondVar + 75
3   org.mozilla.firefox            	0x003021b5 nsIOThreadPool::ThreadFunc(void*) + 145
4   libnspr4.dylib                 	0x00edaffd PR_Select + 813
5   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 10:
0   libSystem.B.dylib              	0x90047dd7 semaphore_timedwait_signal_trap + 7
1   libnspr4.dylib                 	0x00ed6694 PR_Lock + 246
2   libnspr4.dylib                 	0x00ed69eb PR_WaitCondVar + 75
3   org.mozilla.firefox            	0x0059d90a nsHostResolver::GetHostToLookup(nsHostRecord**) + 212
4   org.mozilla.firefox            	0x0059e0b7 nsHostResolver::ThreadFunc(void*) + 123
5   libnspr4.dylib                 	0x00edaffd PR_Select + 813
6   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0x3765a0ff  ebx: 0x00e5a896  ecx: 0xbfff8f3c  edx: 0x06159f6b
  edi: 0x06159f6b  esi: 0x3765a0ff  ebp: 0xbfff8f48  esp: 0xbfff8f10
   ss: 0x0000001f  efl: 0x00010206  eip: 0x01af2b65   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037

Binary Images Description:
    0x1000 -   0x98dfff org.mozilla.firefox 2.0.0.11	/Applications/Firefox.app/Contents/MacOS/firefox-bin
  0xc1b000 -   0xcacfff libmozjs.dylib 	/Applications/Firefox.app/Contents/MacOS/libmozjs.dylib
  0xcc7000 -   0xcc7fff libxpcom.dylib 	/Applications/Firefox.app/Contents/MacOS/libxpcom.dylib
  0xccb000 -   0xcd0fff libplds4.dylib 	/Applications/Firefox.app/Contents/MacOS/libplds4.dylib
  0xcd5000 -   0xcdbfff libplc4.dylib 	/Applications/Firefox.app/Contents/MacOS/libplc4.dylib
  0xce1000 -   0xcf0fff libxpcom_compat.dylib 	/Applications/Firefox.app/Contents/MacOS/libxpcom_compat.dylib
  0xe05000 -   0xe75fff libxpcom_core.dylib 	/Applications/Firefox.app/Contents/MacOS/libxpcom_core.dylib
  0xec0000 -   0xee5fff libnspr4.dylib 	/Applications/Firefox.app/Contents/MacOS/libnspr4.dylib
  0xef6000 -   0xf0ffff libsmime3.dylib 	/Applications/Firefox.app/Contents/MacOS/libsmime3.dylib
  0xf1b000 -   0xf3bfff libssl3.dylib 	/Applications/Firefox.app/Contents/MacOS/libssl3.dylib
  0xf45000 -   0xf9bfff libnss3.dylib 	/Applications/Firefox.app/Contents/MacOS/libnss3.dylib
 0x1808000 -  0x184efff libsoftokn3.dylib 	/Applications/Firefox.app/Contents/MacOS/libsoftokn3.dylib
 0x18b4000 -  0x18bcfff libmyspell.dylib 	/Applications/Firefox.app/Contents/MacOS/components/libmyspell.dylib
 0x1ae8000 -  0x1af2fff libjsd.dylib 	/Applications/Firefox.app/Contents/MacOS/components/libjsd.dylib
 0x1b73000 -  0x1be0fff com.DivXInc.DivXDecoder 6.6.0	/Library/QuickTime/DivX Decoder.component/Contents/MacOS/DivX Decoder
 0x1ddf000 -  0x1de0fff com.apple.textencoding.unicode 2.1	/System/Library/TextEncodings/Unicode Encodings.bundle/Contents/MacOS/Unicode Encodings
0x15e7a000 - 0x15ed7fff libfreebl3.dylib 	/Applications/Firefox.app/Contents/MacOS/libfreebl3.dylib
0x15ee8000 - 0x15ef2fff libspellchecker.dylib 	/Applications/Firefox.app/Contents/MacOS/components/libspellchecker.dylib
0x16229000 - 0x1625afff libnssckbi.dylib 	/Applications/Firefox.app/Contents/MacOS/libnssckbi.dylib
0x1b808000 - 0x1be05fff com.macromedia.Flash Player.plugin 9.0.115 (1.0.4f60)	/Library/Internet Plug-Ins/Flash Player.plugin/Contents/MacOS/Flash Player
0x8f8c0000 - 0x8f95ffff com.apple.QuickTimeImporters.component 7.4 (92)	/System/Library/QuickTime/QuickTimeImporters.component/Contents/MacOS/QuickTimeImporters
0x8fe00000 - 0x8fe4afff dyld 46.16	/usr/lib/dyld
0x90000000 - 0x90171fff libSystem.B.dylib 	/usr/lib/libSystem.B.dylib
0x901c1000 - 0x901c3fff libmathCommon.A.dylib 	/usr/lib/system/libmathCommon.A.dylib
0x901c5000 - 0x90202fff com.apple.CoreText 1.1.3 (???)	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreText.framework/Versions/A/CoreText
0x90229000 - 0x902fffff ATS 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/ATS
0x9031f000 - 0x90774fff com.apple.CoreGraphics 1.258.77 (???)	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
0x9080b000 - 0x908d3fff com.apple.CoreFoundation 6.4.9 (368.31)	/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x90911000 - 0x90911fff com.apple.CoreServices 10.4 (???)	/System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x90913000 - 0x90a07fff libicucore.A.dylib 	/usr/lib/libicucore.A.dylib
0x90a57000 - 0x90ad6fff libobjc.A.dylib 	/usr/lib/libobjc.A.dylib
0x90aff000 - 0x90b63fff libstdc++.6.dylib 	/usr/lib/libstdc++.6.dylib
0x90bd2000 - 0x90bd9fff libgcc_s.1.dylib 	/usr/lib/libgcc_s.1.dylib
0x90bde000 - 0x90c51fff com.apple.framework.IOKit 1.4.8 (???)	/System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x90c66000 - 0x90c78fff libauto.dylib 	/usr/lib/libauto.dylib
0x90c7e000 - 0x90f24fff com.apple.CoreServices.CarbonCore 682.28	/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
0x90f67000 - 0x90fcffff com.apple.CoreServices.OSServices 4.1	/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
0x91008000 - 0x91047fff com.apple.CFNetwork 129.22	/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
0x9105a000 - 0x9106afff com.apple.WebServices 1.1.3 (1.1.0)	/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/WebServicesCore.framework/Versions/A/WebServicesCore
0x91075000 - 0x910f4fff com.apple.SearchKit 1.0.7	/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit
0x9112e000 - 0x9114cfff com.apple.Metadata 10.4.4 (121.36)	/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata
0x91158000 - 0x91166fff libz.1.dylib 	/usr/lib/libz.1.dylib
0x91169000 - 0x91308fff com.apple.security 4.5.2 (29774)	/System/Library/Frameworks/Security.framework/Versions/A/Security
0x91406000 - 0x9140efff com.apple.DiskArbitration 2.1.2	/System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x91415000 - 0x9141cfff libbsm.dylib 	/usr/lib/libbsm.dylib
0x91420000 - 0x91446fff com.apple.SystemConfiguration 1.8.6	/System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
0x91458000 - 0x914cefff com.apple.audio.CoreAudio 3.0.5	/System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
0x9151f000 - 0x9151ffff com.apple.ApplicationServices 10.4 (???)	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x91521000 - 0x9154dfff com.apple.AE 314 (313)	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
0x91560000 - 0x91634fff com.apple.ColorSync 4.4.10	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ColorSync.framework/Versions/A/ColorSync
0x9166f000 - 0x916e2fff com.apple.print.framework.PrintCore 4.6 (177.13)	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore
0x91710000 - 0x917b9fff com.apple.QD 3.10.25 (???)	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/QD.framework/Versions/A/QD
0x917df000 - 0x9182afff com.apple.HIServices 1.5.2 (???)	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/HIServices
0x91849000 - 0x9185ffff com.apple.LangAnalysis 1.6.3	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LangAnalysis.framework/Versions/A/LangAnalysis
0x9186b000 - 0x91886fff com.apple.FindByContent 1.5	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/FindByContent.framework/Versions/A/FindByContent
0x91891000 - 0x918cefff com.apple.LaunchServices 182	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
0x918e2000 - 0x918eefff com.apple.speech.synthesis.framework 3.5	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/SpeechSynthesis
0x918f5000 - 0x91935fff com.apple.ImageIO.framework 1.5.6	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
0x91948000 - 0x919fafff libcrypto.0.9.7.dylib 	/usr/lib/libcrypto.0.9.7.dylib
0x91a40000 - 0x91a56fff libcups.2.dylib 	/usr/lib/libcups.2.dylib
0x91a5b000 - 0x91a79fff libJPEG.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libJPEG.dylib
0x91a7e000 - 0x91addfff libJP2.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libJP2.dylib
0x91aef000 - 0x91af3fff libGIF.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libGIF.dylib
0x91af5000 - 0x91b7dfff libRaw.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libRaw.dylib
0x91b81000 - 0x91bbefff libTIFF.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
0x91bc4000 - 0x91bdefff libPng.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libPng.dylib
0x91be3000 - 0x91be5fff libRadiance.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libRadiance.dylib
0x91be7000 - 0x91cc5fff libxml2.2.dylib 	/usr/lib/libxml2.2.dylib
0x91ce2000 - 0x91ce2fff com.apple.Accelerate 1.3.1 (Accelerate 1.3.1)	/System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
0x91ce4000 - 0x91d72fff com.apple.vImage 2.5	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework/Versions/A/vImage
0x91d79000 - 0x91d79fff com.apple.Accelerate.vecLib 3.3.1 (vecLib 3.3.1)	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
0x91d7b000 - 0x91dd4fff libvMisc.dylib 	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvMisc.dylib
0x91ddd000 - 0x91e01fff libvDSP.dylib 	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvDSP.dylib
0x91e09000 - 0x92212fff libBLAS.dylib 	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
0x9224c000 - 0x92600fff libLAPACK.dylib 	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib
0x9262d000 - 0x9271afff libiconv.2.dylib 	/usr/lib/libiconv.2.dylib
0x9271c000 - 0x9279afff com.apple.DesktopServices 1.3.7	/System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/DesktopServicesPriv
0x927db000 - 0x92a0bfff com.apple.Foundation 6.4.9 (567.36)	/System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x92b25000 - 0x92b3cfff libGL.dylib 	/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
0x92b47000 - 0x92b9ffff libGLU.dylib 	/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLU.dylib
0x92bb3000 - 0x92bb3fff com.apple.Carbon 10.4 (???)	/System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x92bb5000 - 0x92bc5fff com.apple.ImageCapture 3.0.4	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/ImageCapture.framework/Versions/A/ImageCapture
0x92bd4000 - 0x92bdcfff com.apple.speech.recognition.framework 3.6	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SpeechRecognition.framework/Versions/A/SpeechRecognition
0x92be2000 - 0x92be8fff com.apple.securityhi 2.0.1 (24742)	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SecurityHI.framework/Versions/A/SecurityHI
0x92bee000 - 0x92c7ffff com.apple.ink.framework 101.2.1 (71)	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Ink.framework/Versions/A/Ink
0x92c93000 - 0x92c97fff com.apple.help 1.0.3 (32.1)	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Help.framework/Versions/A/Help
0x92c9a000 - 0x92cb8fff com.apple.openscripting 1.2.5 (???)	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting.framework/Versions/A/OpenScripting
0x92cca000 - 0x92cd0fff com.apple.print.framework.Print 5.2 (192.4)	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Print.framework/Versions/A/Print
0x92cd6000 - 0x92d39fff com.apple.htmlrendering 66.1 (1.1.3)	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HTMLRendering.framework/Versions/A/HTMLRendering
0x92d60000 - 0x92da1fff com.apple.NavigationServices 3.4.4 (3.4.3)	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/NavigationServices.framework/Versions/A/NavigationServices
0x92dc8000 - 0x92dd6fff com.apple.audio.SoundManager 3.9.1	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CarbonSound.framework/Versions/A/CarbonSound
0x92ddd000 - 0x92de2fff com.apple.CommonPanels 1.2.3 (73)	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CommonPanels.framework/Versions/A/CommonPanels
0x92de7000 - 0x930dcfff com.apple.HIToolbox 1.4.10 (???)	/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
0x931e2000 - 0x931edfff com.apple.opengl 1.4.16	/System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
0x9325d000 - 0x9325dfff com.apple.Cocoa 6.4 (???)	/System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x9325f000 - 0x93915fff com.apple.AppKit 6.4.9 (824.44)	/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
0x93c96000 - 0x93d11fff com.apple.CoreData 91 (92.1)	/System/Library/Frameworks/CoreData.framework/Versions/A/CoreData
0x93d4a000 - 0x93e03fff com.apple.audio.toolbox.AudioToolbox 1.4.7	/System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
0x93e46000 - 0x93e46fff com.apple.audio.units.AudioUnit 1.4.2	/System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit
0x93e48000 - 0x94009fff com.apple.QuartzCore 1.4.12	/System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore
0x9404f000 - 0x94090fff libsqlite3.0.dylib 	/usr/lib/libsqlite3.0.dylib
0x94098000 - 0x940d2fff libGLImage.dylib 	/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLImage.dylib
0x940d7000 - 0x940edfff com.apple.CoreVideo 1.4.2	/System/Library/Frameworks/CoreVideo.framework/Versions/A/CoreVideo
0x94281000 - 0x94290fff libCGATS.A.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCGATS.A.dylib
0x94297000 - 0x942a2fff libCSync.A.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCSync.A.dylib
0x942ee000 - 0x94308fff libRIP.A.dylib 	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libRIP.A.dylib
0x9430e000 - 0x94625fff com.apple.QuickTime 7.4.0 (92)	/System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime
0x95dbb000 - 0x95dd1fff libJapaneseConverter.dylib 	/System/Library/CoreServices/Encodings/libJapaneseConverter.dylib
0x967d2000 - 0x967d2fff com.apple.vecLib 3.3.1 (vecLib 3.3.1)	/System/Library/Frameworks/vecLib.framework/Versions/A/vecLib
0x96e41000 - 0x96e46fff com.apple.agl 2.5.9 (AGL-2.5.9)	/System/Library/Frameworks/AGL.framework/Versions/A/AGL
0x971e4000 - 0x971f8fff com.apple.audio.CoreAudioKit 1.0.1	/System/Library/Frameworks/CoreAudioKit.framework/Versions/A/CoreAudioKit
0x981c1000 - 0x99003fff com.apple.QuickTimeComponents.component 7.4 (92)	/System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents
0x99da0000 - 0x99dd0fff com.apple.QuickTime Plugin.plugin 7.4 (92)	/Library/Internet Plug-Ins/QuickTime Plugin.plugin/Contents/MacOS/QuickTime Plugin

Model: MacBook2,1, BootROM MB21.00A5.B07, 2 processors, Intel Core 2 Duo, 2 GHz, 2 GB
Graphics: Intel GMA 950, GMA 950, Built-In, spdisplays_integrated_vram
Memory Module: BANK 0/DIMM0, 1 GB, DDR2 SDRAM, 667 MHz
Memory Module: BANK 1/DIMM1, 1 GB, DDR2 SDRAM, 667 MHz
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x87), 1.2.2
Bluetooth: Version 1.9.5f4, 2 service, 1 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Network Service: Parallels Host-Guest, Ethernet, en2
Network Service: Parallels NAT, Ethernet, en3
Serial ATA Device: FUJITSU MHV2080BH, 74.53 GB
Parallel ATA Device: HL-DT-ST DVDRW GWA4080MA
USB Device: Built-in iSight, Micron, Up to 480 Mb/sec, 500 mA
USB Device: Macally iKey, Macally, Up to 12 Mb/sec, 500 mA
USB Device: Apple Optical USB Mouse, Mitsumi Electric, Up to 1.5 Mb/sec, 100 mA
USB Device: Macally iKey, Macally, Up to 12 Mb/sec, 100 mA
USB Device: Apple Internal Keyboard / Trackpad, Apple Computer, Up to 12 Mb/sec, 500 mA
USB Device: IR Receiver, Apple Computer, Inc., Up to 12 Mb/sec, 500 mA
USB Device: Bluetooth USB Host Controller, Apple, Inc., Up to 12 Mb/sec, 500 mA
Comment 11 John J. Barton 2008-01-30 12:45:21 PST
Ok, thanks.  That stack is quite different from the one I filed this bug on. I don't think your crash is related to pageads (or firebug for that matter).

It looks like an xpcom - JSRuntime shutdown problem. You might open another bug for it; an important question I would have is "mac only" or not.

John.
Comment 12 Anthony Ettinger 2008-01-30 13:17:28 PST
Verified on Mac OSX and Windows XP Home SP2. see steps above...this is from the Firebug FAQ so I assumed this is related to the "Gmailing crashing w/ Firebug" phenomenon....everyone here @ work sees it too.
Comment 13 John J. Barton 2008-01-30 13:32:25 PST
This bug report is about Google pageads script (not gmail) crashing firefox with firebug installed.  It looks to me as if you have found a different problem which needs its own report to get analysis.  Please cc me on the report.

Some of the other call stacks that you can look at are:
403461  FF2 crasher   | FF Crash [@ nsCSubstring::Equals]
282660  FF2 crasher     | Crash [@ jsds_NotifyPendingDeadScripts] ds->script is null
388993  FF2 crasher | Crash when opening a new tab [@ js_GetScriptLineExtent] [@ NSGetModule]
400532  FF2 big crasher |               jsdIScript.functionSource crashes with Firebug 1.1 adsense, pageads msvcrt.dll
 

Note You need to log in before you can comment on or make changes to this bug.