MOZ_NO_REMOTE doesn't work with -P

RESOLVED DUPLICATE of bug 376216

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED DUPLICATE of bug 376216
11 years ago
10 years ago

People

(Reporter: micmon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007102104 Minefield/3.0a9pre

I try to start a minefield nightly build with 

./firefox -no-remote -P xxx

or

MOZ_NO_REMOTE=1 ./firefox-bin -P xxx

If I try to run a second copy I get a window, telling me I need to close the running copy first. If I understand correctly, the "no remote" part should take care of this and open another window, right? It works on my Ubuntu's Firefox2 build this way, so I suppose there is something broken with FF3

Reproducible: Always
(Reporter)

Comment 1

11 years ago
I have to add: this is really a bad thing because of this:

- I have a firefox3 window open
- I have firefox3 set as the browser that launches when pressing web links in other apps
- I press a link and the window pops up and tells me to close the other browser window. Setting GNOME to load links in a new tab does NOT solve this.

So this really is a problem when working with the system

Comment 2

11 years ago
no-remote explicitly *blocks* the behavior you describe, auto-remoting to the running instance of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

11 years ago
I explained the root of this incorrectly :/

It works fine with the system-installed firefox2. If I want to start a firefox3 beta/nightly I have to use no-remote in order to start it, or I have to close the firefox2 process first.

So I saw the wrong problem. The real problem is that it doesn't seem to be possible to start more than one browser window of *different* firefox versions (using different profiles) at once.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

11 years ago
Could you state the steps to reproduce again/more clearly? If you're running different profiles you indeed shouldn't see the "Firefox is already running" prompt... that is caused by a locked profile.
(Reporter)

Comment 5

11 years ago
Ok, I have two profiles, the default one is for my stable browsing needs (firefox2) and I also have a test profile for ff3 nightlies. I keep the ff2 open most of the time and this works nice: if I have to start another winow, it just does it.

Now, If I also want to start the ff3 nightly for some regression testing etc, I have to do this with: ./firefox -no-remote -P xxx (from the nightly derectory). If I don't use "-no-remote", then I will get a window of ff2 with the test profile, not the nightly as I intended. I guess this should not be the case?

The problem also exist the other way around: if I start ff3 (xxx profile) before any window of ff2 (default) and then try to start ff2 (default), I get the nigtly starting the default profile, not my stable ff2, as it should be.

Comment 6

11 years ago
Issue 1 is bug 376216, not a high priority

Issue 2 should be a nightly continuing to run with a new window in profile xxx.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376216
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.