CSS with overflow: and float: causing incorrect rendering.

RESOLVED DUPLICATE of bug 290146

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 290146
10 years ago
10 years ago

People

(Reporter: Igor Belyi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071004 Iceweasel/2.0.0.8 (Debian-2.0.0.8-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071004 Iceweasel/2.0.0.8 (Debian-2.0.0.8-1)

The following simple web page does not produce the correct result in Firefox:

<html>
<head>
<title>Test Page</title>
</head>
<body>
<ul style="float:left; width:100%">
<li>Item one</li>
</ul>
<div style="overflow:auto">This text should be visible!</div>
</body>
</html>

If I remove any of the style elements or the <li> item - the text "This text should be visible!" becomes visible. I can reproduce this problem in different Linux distributions and under MS Windows. It is reproducable with the latest (at the moment) Firefox 2.0.0.8


Reproducible: Always

Steps to Reproduce:
1. Save the example web page text into a file.
2. Open this file in a Firefox.

Actual Results:  
Text "This text should be visible!" is not visible.

Expected Results:  
The text should be visible.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 391412
(Reporter)

Comment 2

10 years ago
On MS Windows I've installed "Bon Echo" from http://ftp.mozilla.org/pub/mozila.org/firefox/nightly/2007-10-22-04-mozilla1.8/ and it still has this problem. I also installed "Minefield" from http://ftp.mozilla.org/pub/mozila.org/firefox/nightly/2007-10-22-05-trunk/ and it still has this problem as well.

Could you verify that this problem is a duplicate of the fixed 391412? In which build this fix is (will be?) available?

Thanks,
Igor
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

10 years ago
Mistyped the name of the sites (mozila.org instead of mozilla.org).. Here's the correct references:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007-10-22-04-mozilla1.8/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007-10-22-05-trunk/

Igor

Comment 4

10 years ago
Created attachment 285761 [details]
Testcase

Testcase fails using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8pre) Gecko/20071022 BonEcho/2.0.0.8pre ID:2007102204
This is basically the same as bug 290146 (with "auto" instead of "hidden", but it's the same basic thing going on).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 290146
You need to log in before you can comment on or make changes to this bug.