Closed Bug 400749 Opened 14 years ago Closed 14 years ago

Disabled Text Input Field Does Not Show Title="This should display" As Tooltip.

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 274626

People

(Reporter: ralberts, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

If I have the following code:

<input name="textfield" title="This should display tooltip" type="text" disabled="disabled" value="This is the value." />

You will noticed that the input field is set to disabled and that I have a title attribute.  It seems that if the text field is not set to disabled it shows the title attribute correctly as a tooltip but if disabled it does not show.

As a comparison you can load my test page up in IE and it will show the tooltip.

Reproducible: Always

Steps to Reproduce:
1. Create a webpage that with the following in the code:
<input name="textfield" title="This should display tooltip" type="text" disabled="disabled" value="This is the value." />
Optionally, you can visit http://meetmeonthe.net/testField.html.
2. Load in Firefox and put your mouse over the text box disabled text box.
3. You will notice that a tooltip is not shown.
4. If you put your mouse over the box that is not disabled it shows up correctly.
Actual Results:  
You will notice that a tooltip is not shown.

Expected Results:  
The tooltip should show up displaying what was put in the "title" attribute of the input element.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 274626
You need to log in before you can comment on or make changes to this bug.