Closed Bug 400911 Opened 14 years ago Closed 14 years ago

pop up loads over page but will not go away when closed

Categories

(Firefox :: General, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 227072

People

(Reporter: lillyput, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

This is a spades League I have joined.  I cannot see all the page because of this problem.  I tried IE and it closes fine after being read.

Reproducible: Always

Steps to Reproduce:
1.Just go to the URL listed above.
2.Wait for pop up box to load .
3.Click close box
Actual Results:  
the text inside the pop up goes but the box remains as a large blue area on left of page.


The pop up box should dissappear altogether when close box is selected. I have screen shots in paint of IE handling of this problem and Firefox handling if required.
Reporter, 
I can confirm your findings with your steps to reproduce. Thank you for doing this correctly. Firefox 2.0.0.8 under XP Pro SP2.

This is not a secondary window or a real secondary window or a Java applet window but rather a DHTML layer occuring inside an iframed webpage, first hidden, then made visible and then moved with setTimeout, etc.:

<iframe id="dbifrmd" allowtransparency="true" frameborder="0" height="450px" marginheight="0px" marginwidth="0px" scrolling="no" width="500px" src="http://www.members.aol.com:/barnabus1961/dropin2.html"> </iframe> 

If you load this page
http://www.members.aol.com/barnabus1961/dropin2.html
and then click the red "Close box", then the blue background page will not disappear. The red box is a DHTML layer inside that barnabus1961/dropin2.html webpage.

When you load the iframe, the document creates the red box with 
function initbox(): it moves according to the javascript function.

<body bgcolor="transparent" (...)>

I understand what is the problem now: bgcolor="transparent" is not supported by Mozilla software where it seems it is for MSIE 7. Hmm...
A bit of search would be needed here to verify what Firefox do in quirks mode when 
<iframe allowtransparency="true" ...>
and 
<body bgcolor="transparent" (...)>
are being used.

Testcase coming
Load this testcase in Firefox 2 and in MSIE 7. That webpage is in quirks mode in both browsers. bgcolor="transparent" gives different background colors in both browsers. Firefox 2 sets it to blue when MSIE 7 sets it to whichever color is chosen in Tools/Options/General/Colors
Reporter, one workaround is to use Adblock Plus 0.7.5.3: I used it for the iframe at http://www.myleague.com/teamnutthouse/ and it worked.

If you can reach that website webdeveloper, then inform him that transparency for <body> and/or <iframe> are not rendered the same in different browser; they are first of all invalid markup code. All he has to do is to size correctly the DHTML layer and then dynamically set it to display: none when the close box link is clicked. There is no need whatsoever for bgcolor="transparent" and there is no need whatsoever for an iframe in the MAIN frame.
Got it! Bug 227072 for bgcolor="transparent"

For allowtransparency, there is no bug for this.
By default, iframe background is transparent (bug 154957, bug 50623). So, setting allowtransparency="true" or not will do the same in Firefox.

So, I'm resolving this bug as a DUPLICATE of bug 227072
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 227072
You need to log in before you can comment on or make changes to this bug.