ecma3/Math/e15_8_2_12:Infinity/Math.min(0,-0) testcase fails when running the release vm with the -Dinterp vm arg

VERIFIED FIXED

Status

VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: brbaker, Unassigned)

Tracking

unspecified
Bug Flags:
in-testsuite +
flashplayer-triage +

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: 198:c54d42df101e

FAILURES:
  ecma3/Math/e15_8_2_12.abc : Infinity/Math.min(0,-0) = Infinity FAILED! expected: -Infinity

Reproducible: Always

Steps to Reproduce:
1. run the test tests/ecma3/Math/e15_8_2_12.as with the release vm while passing in the -Dinterp switch

Actual Results:  
Infinity/Math.min(0,-0) = Infinity

Expected Results:  
Infinity/Math.min(0,-0) = -Infinity
(Reporter)

Comment 1

11 years ago
Created attachment 286970 [details] [diff] [review]
Exclude testcase when running -interp

Mark the testcase as an expectedfail until this has been addressed.
Attachment #286970 - Flags: review?(dschaffe)

Updated

11 years ago
Attachment #286970 - Flags: review?(dschaffe) → review+

Comment 2

11 years ago
submitted patch for marking testcase as expected fail when running in -interp mode.  Ran tests in jit and interp to confirm.

Comment 3

11 years ago
This is caused by the wrong implementation of MathClass::min() in MathClass.cpp. "if(y < x)" can not compare +0.0 and -0.0. Mozilla js engine has a correct version of min max. http://lxr.mozilla.org/mozilla/source/js/src/jsmath.c#270

Updated

11 years ago
Duplicate of this bug: 424461

Comment 5

11 years ago
Created attachment 311988 [details] [diff] [review]
patch

I have tested it on mac, linux, solaris and windows. I don't have arm so I just guess it is right.
Attachment #311988 - Flags: review?(treilly)

Comment 6

11 years ago
That appears to be an expedient and correct fix.  (It's how I would have done it too.)

Updated

11 years ago
Attachment #311988 - Flags: review?(treilly) → review+

Comment 7

11 years ago
Seems there are a lot of failures in http://tamarin-builds.mozilla.org/tamarin-central/waterfall. Is that because I didn't remove the testcase from testconfig.txt?

Comment 8

11 years ago
Created attachment 312216 [details] [diff] [review]
Patch to remove the testcase from testconfig.txt

Updated

11 years ago
Attachment #312216 - Flags: review?(dschaffe)
(Reporter)

Updated

11 years ago
Attachment #312216 - Flags: review+
(Reporter)

Comment 9

11 years ago
Pushed in the patch as 489:723a002c9012

Comment 10

11 years ago
Thanks Brent.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Attachment #312216 - Flags: review?(dschaffe)
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
Flags: flashplayer-triage+
You need to log in before you can comment on or make changes to this bug.