[P-MARGIN] Quirk Bug: Empty P between two blocks has no vertical space

VERIFIED DUPLICATE of bug 35772

Status

()

Core
Layout
P2
normal
VERIFIED DUPLICATE of bug 35772
18 years ago
18 years ago

People

(Reporter: Matthew Cline, Assigned: buster)

Tracking

({compat, testcase})

Trunk
x86
All
compat, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wdormann@crosswinds.net, URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Banner ads on Slashdot have no vertical space between them and the rest of
the page content, like they should.

Comment 1

18 years ago
Confirmed on 2000052120 on Win2K
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Keywords: makingtest
Whiteboard: wdormann@crosswinds.net

Comment 2

18 years ago
Created attachment 8961 [details]
Simplified case of this bug

Updated

18 years ago
Keywords: makingtest → testcase
OS: Linux → All

Comment 3

18 years ago
It appears that when a <p> is sandwiched between two tables, it is ignored.
(a <p> between 2 images or between a table and an image works fine)

Comment 4

18 years ago
wdormann, thanks for the testcase!

This problem is QuirkMode only: in Standard mode we get vertical spacing 
consistently.

The problem is more general than originally stated and is not restricted to 
tables. I'll attach a testcase showing that having an empty P between two blocks 
causes the problem. If the empty P is between an inline and a block, or between 
two inlines then there is no problem.

Re-phrasing the summary and assigning to buster. New testcase will be attached.
Assignee: clayton → buster
Summary: Banner ads on Slashdot have no space under them → Quirk Bug: Empty P between two blocks has no vertical space

Comment 5

18 years ago
Created attachment 8976 [details]
New testcase showing behavior in all three cases (see comments of 5/22)

Comment 6

18 years ago
related: bug 29361

what happens when the <p> tag is closed below the second element?
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2
(Assignee)

Updated

18 years ago
Summary: Quirk Bug: Empty P between two blocks has no vertical space → [P-MARGIN] Quirk Bug: Empty P between two blocks has no vertical space
Marking compat. Nom. nsbeta3, recc. nsbeta3 [some lenient date-]. Ps were
historically widely consider as (and used as) "spacers" so I suspect there's a
fair amount of this out there. Would like to emulate in quirks but wouldn't hold
rtm for it.
Keywords: compat, nsbeta3
(Assignee)

Comment 8

18 years ago
I reduced this down and found it's just a dup.  Already fixed in my tree, to be 
checked in soon.

*** This bug has been marked as a duplicate of 35772 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.