New tabs lose history so can't go back

RESOLVED DUPLICATE of bug 18808

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 18808
11 years ago
11 years ago

People

(Reporter: gene-firefox, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

When one opens a link in a new tab (shift-click) the history (previous pages queue) is lost so you can't go back. It would be really useful if the list of previous (an foward) pages was copied to the new tab.

Sometimes the new tab becomes the main thread of visited pages and I want to go back to before I branched into a new tab.

Reproducible: Always

Steps to Reproduce:
1. open http://www.mozilla.com/en-US/
2. shift-click "Firefox 2" (http://www.mozilla.com/en-US/firefox/)
3. click on the tab to switch to the new page
4. click the back button <-

Actual Results:  
nothing happens as you can't go back
the button is disabled

Expected Results:  
go back to the page (mozilla) I was on before I got to the firefox page
(Reporter)

Updated

11 years ago

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 18808
You need to log in before you can comment on or make changes to this bug.