Crash with Corel Linux when saving/opening files (segv)

VERIFIED INVALID

Status

SeaMonkey
General
P3
critical
VERIFIED INVALID
18 years ago
13 years ago

People

(Reporter: Chris Fonnesbeck, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
It seems that any interaction with the file system causes Mozilla to crash.  The
"Save as" dialog box opens up but as soon as you press "OK", a segfault occurs. 
This happens EVERY TIME.

System: CorelLinux with updates for glibc, ldso, libc6.
Build: 2000052120

Here is a tail of the strace:

Warning - table cell content max element height 300 greater than desired height
285
Warning - table cell content max element height 300 greater than desired height
285
Document: Done (1.61 secs)
Document http://www.mozilla.org/ loaded successfully
           All Files *.*
.//run-mozilla.sh: line 29:  4201 Segmentation fault      $prog ${1+"$@"}
[WIFEXITED(s) && WEXITSTATUS(s) == 0], 0, NULL) = 4196
SYS_175(0, 0xbffffa74, 0xbffff9f4, 0x8, 0) = 0
SYS_175(0x2, 0xbffff9f4, 0, 0x8, 0x2)   = 0
SYS_175(0, 0xbffffa78, 0xbffff9f8, 0x8, 0) = 0
SYS_175(0x2, 0xbffff9f8, 0, 0x8, 0x2)   = 0
SYS_175(0x2, 0xbffffb18, 0, 0x8, 0x2)   = 0
--- SIGCHLD (Child exited) ---
wait4(-1, 0xbffff9cc, WNOHANG, NULL)    = -1 ECHILD (No child processes)
sigreturn()                             = ? (mask now [])
SYS_174(0x2, 0xbffff918, 0xbffff88c, 0x8, 0x2) = 0
SYS_175(0, 0, 0x80b4384, 0x8, 0)        = 0
SYS_175(0, 0xbffff368, 0xbffff2e8, 0x8, 0) = 0
SYS_175(0x2, 0xbffff2e8, 0, 0x8, 0x2)   = 0
SYS_175(0, 0xbffff36c, 0xbffff2ec, 0x8, 0) = 0
SYS_175(0x2, 0xbffff2ec, 0, 0x8, 0x2)   = 0
read(3, "", 44)                         = 0
_exit(0)

Comment 1

18 years ago
Moving from "other" to "Browser-General", reassigning to default owner,
crash kw, severity critical. 

Something similar has been reported in bug 28625 on RedHat 6.0. (current status
of that bug is VERIFIED WORKSFORME, but the reporter still sees the problem). I
think it's worth to track this down. 

chrisf@fonnesbeck.net: Please try if this also occurs with a recent nightly.
If noone else sees this, a stack trace could be of much help. Could you try
the talkback version of M15 and send a crash report? Another possibility is
to download a recent nightly and run it in gdb. I don't know if it works on
Corel Linux, but at http://www.ags.uni-sb.de/~afranke/mozilla/quick-gdb.html 
there is a short step-by-step guide describing how to get stack traces for
mozilla nightly builds with gdb on SuSE 6.2. It also links to the official
mozilla "Debugging on Linux" FAQ.
Assignee: chofmann → asadotzler
Severity: major → critical
Component: other → Browser-General
Keywords: crash
QA Contact: leger → jelwell

Comment 2

18 years ago
Quoted from Chris' answer:

> The bug was submitted after crashing today's nightly build, and it has crashed
> pretty much every build in recent memory (at least back to M14).  The stack
> trace wasnt very helpful, but I have included it below.  I dont get a gdb
> prompt back after the segfault:
> 
> Warning - table cell content max element height 300 greater than desired
height 285
> Warning - table cell content max element height 300 greater than desired
height 285
> Document: Done (3.515 secs)
> Document http://www.mozilla.org/mozorg.html loaded successfully
>            All Files *.*
> (no debugging symbols found)...(no debugging symbols found)...
>  
> [1]+  Stopped                 ./mozilla -g -d gdb 
> fisher:/usr/local/mozilla$   
> 
> I will try a talkback version.
>
> cjf

Sorry, I overlooked the fact that the reported build ID was a current nightly,
because the summary said M15. Updating.

Are you sure that your gdb is up-to-date? Try gdb --version. If it's something
like 4.18, the problem may be that it can't deal with threads. In this case,
please try a new version (4.95.0 or later). You can get it from
http://sourceware.cygnus.com/gdb/5/
Summary: M15 segfaults when saving/opening files → Crash with Corel Linux when saving/opening files (segv)

Comment 3

18 years ago
Reporter, can you duplicate this after completely erasing ~/.mozilla and
possibly with a newer build? This tends to cure most problems...
(Assignee)

Comment 4

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 5

18 years ago
due to lack of feedback, marking invalid. reopen if oyu see this wiht new builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 6

18 years ago
vrfy invalid for now, need more info from the reporter before we can go any 
further.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.