Download to a disconnected drive

VERIFIED DUPLICATE of bug 429827

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 429827
11 years ago
10 years ago

People

(Reporter: Leonardo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007102304 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007102304 Minefield/3.0a9pre

If you set your downloads folder to an external drive, such as a USB pendrive, then remove it, then download something, Minefield doesn't tell you anything. It doesn't give an error, nothing. At least it should say "Could not locate the downloads folder" or something like that. Maybe relocate the downloads to the desktop momentarily would be helpful in this case.

Reproducible: Didn't try

Steps to Reproduce:
1.Set your downloads folder to an external drive
2.Remove the external drive
3.Download a file, like a .exe
4.Go to Tools > Downloads and you will see nothing
(In reply to comment #0)
>  At least it should say "Could not locate the downloads folder" or something like that.
> Maybe relocate the downloads to the desktop momentarily would be helpful in this case.

Current design in such case is; a) no feed back/no annoying dialog, b) automatic fall back to directory such as last downloaded directory, MRU(most recently used directory), desktop, working directory(=current directory=program directory).
Sorry but I don't know detailed fall back order or final fall back location.
See Bug 394910 for current fall back (and existing problems in choice/fall back).

> Steps to Reproduce:
> 1.Set your downloads folder to an external drive
> 2.Remove the external drive
> 3.Download a file, like a .exe
> 4.Go to Tools > Downloads and you will see nothing

Sounds "(no filepicker prompt)" case of Bug 394910 Comment #8, and problem of "silent stop of download when unable to fall back".
(Q1) What is set(or defauled, or not set) in next entries?
(about:config at URL bar, then filter with "download")
 - browser.download.folderList
 - browser.download.useDownloadFolder
 - browser.download.dir
 - browser.download.lastDir
(Q2) What is your exact operation at step 3?
 a. link click of <a href="....exe">
 b. "Save As"(or "Save Image As" when image)
 c. "Save Link As"
Resolving old UNCONFIRMED Download Manager bugs as INCOMPLETE.  If you still see this issue, please reopen.

To mark all these bug changes as read, filter on ONOMATOPOEIA.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 429827
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.