Closed Bug 401238 Opened 14 years ago Closed 14 years ago

if options are set to prevent pages from using their own colors, no backgrounds at all on menus

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 255411

People

(Reporter: mgoodfel, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

If you set Tools/Options/Colors to prevent pages from using their own colors, script-created menus, drop-downs, flyovers on the page will have no background at all.  They will be transparent, the flyover text will overwrite the page, and they will be nearly unusable.  See any page with flyovers or menus, such as the NetFlix queue page.

Just paint the flyovers with the default background page color in this case.  Should be simple fix!

Reproducible: Always

Steps to Reproduce:
1.Tools/Options/Colors, uncheck "allow pages to choose their own colors"
2.Go to NetFlix queue page or other page with script-created menus or flyovers
3.popup flyover.  No background is drawn.
I believe this was fixed on trunk in bug 255411.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 255411
You need to log in before you can comment on or make changes to this bug.