Blank Name field causes silent failure.

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: hutnick, Assigned: mfinkle)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: 0.8

When I try to create a new "app", if I leave the "name" field blank then select OK a lager window appears for a moment, and then the app seems to exit silently.  The new shortcut isn't created.

Reproducible: Always

Steps to Reproduce:
1. Launch Prism
2. Enter a URL (but not a name).
3. Select OK.
Actual Results:  
App exits.

Expected Results:  
Error indicating that "Name" is required.

Comment 1

11 years ago
confirmed...I tried this on my machine and yes it does give the message as said above.
Thanks for reporting. If somebody can mentor me, I can fix it up.
Component: Prism → Prism
Product: Other Applications → Mozilla Labs
(Assignee)

Comment 2

11 years ago
(In reply to comment #1)
> confirmed...I tried this on my machine and yes it does give the message as said
> above.
> Thanks for reporting. If somebody can mentor me, I can fix it up.
> 

in "install-shortcut.js", the "accept" we should check that the "name.value" is
not empty. If it is, we should display a message and return false.

Have a go if you want

Comment 3

11 years ago
Thanks Mark.Yes i got the point where you are pointing. Can you tell me how can i test the things on local desktop or if you can point me to some documentation and for rest of procedure then I can do it?
Thanks
Yogesh
(Assignee)

Comment 4

11 years ago
(In reply to comment #3)
> Thanks Mark.Yes i got the point where you are pointing. Can you tell me how can
> i test the things on local desktop or if you can point me to some documentation
> and for rest of procedure then I can do it?
> Thanks
> Yogesh
> 

You can make changes to the javascript in the file and then run Prism to test the changes.

However, this bug is very related to another, bug 401201, so I will likely fix both with the same patch.

I'd still encourage you to make changes and try to test them - it will come in handy for when you fix the next bug :)
Assignee: nobody → mark.finkle

Comment 5

11 years ago
Thanks Mark. You can go ahead with the patch and i will do the changes and see if it works for me.
(Assignee)

Comment 6

11 years ago
fixed by patch in bug 401201
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.