Apostrophe activates "Find", Backslash also problematic in text areas many sites

RESOLVED DUPLICATE of bug 311376

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 311376
11 years ago
11 years ago

People

(Reporter: Cecilia Tan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

I thought this might be a Mac OS problem but I tested it now on PCs running Windows XP also. While typing text into normal text areas like a GMail message window or a Livejournal 'post' box, the apostrophe key activates the "Find" bar if Firefox. Also had similar problems with backslash.

What is curious is that it will be broken in one window, but working fine in another! (Example, it was doing it in Gmail, but not doing it in another window open simultaneously to liveJournal).

Intermittent. Does not always do it.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Firefox.
2. Open a website such as LJ or Gmail.
3. Type text like normal. 
Actual Results:  
Sometimes it happens, sometimes it doesn't. Restarting FF "fixes" it sometimes, and sometimes it doesn't.

Expected Results:  
Typing the apostrophe in a word like "you're" should have produced the word "you're," instead of "you   and then putting up the FIND bar.

This happens enough that it's made Firefox useless for me until it is fixed. If I cannot type email or post to web sites, it's pretty much useless. And avoiding ever using the apostrophe is NOT a good workaround.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311376
You need to log in before you can comment on or make changes to this bug.