Closed Bug 401395 Opened 13 years ago Closed 13 years ago

Hang moving nodes in and out of display: none node

Categories

(Core :: Disability Access APIs, defect)

x86
All
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: aaronlev)

References

(Blocks 1 open bug)

Details

(Keywords: hang, regression, testcase)

Attachments

(1 file)

1.69 KB, application/xhtml+xml
Details
Attached file testcase
See testcase, which hangs in current trunk build while loading.
You need to download the testcase to your computer, because of the use of enhanced privileges.

This seems to have regressed between 2007-09-28 and 2007-09-29:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-09-28+04&maxdate=2007-09-29+06&cvsroot=%2Fcvsroot
Not sure what made it regress, there were multiple check-ins regarding accessibility.
doesn't hang for me with patch from the bug 398021.
Blocks: fox3access
Depends on: 398021
Martijn, this should be fixed now, since we just checked in bug 398021.
Thanks, I'll check in tomorrow's build which has the fix from bug 398021 in.
This is still hanging for me, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007111605 Minefield/3.0b2pre
I think this bug is caused by delayed invalidation, which is not addressed by bug 398021 in its later patch.

see
https://bugzilla.mozilla.org/show_bug.cgi?id=398021#c50 and 
https://bugzilla.mozilla.org/show_bug.cgi?id=398021#c52
Blocks: 397112
the fix was checked in within bug 408997
Status: NEW → RESOLVED
Closed: 13 years ago
OS: Windows XP → All
Resolution: --- → FIXED
Flags: in-testsuite?
Verified fixed, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011604 Minefield/3.0b3pre
Status: RESOLVED → VERIFIED
I am seeing these assertions, though, in a debug build with the testcase:
(the replaceelement assertion happens a lot)
###!!! ASSERTION: ReplaceElementAt(negative index): 'aIndex >= 0', file c:/mozil
la-build/mozilla/_firefox/xpcom/build/nsVoidArray.cpp, line 491

###!!! ASSERTION: Hypertext is reporting a different accessible for this node: '
!changeAccessible || changeAccessible == aAccessibleForChangeNode', file c:/mozi
lla-build/mozilla/accessible/src/base/nsDocAccessible.cpp, line 1355
You need to log in before you can comment on or make changes to this bug.