need getter_InOut for XPIDL inout string params

RESOLVED DUPLICATE of bug 53065

Status

()

Core
String
P3
enhancement
RESOLVED DUPLICATE of bug 53065
18 years ago
18 years ago

People

(Reporter: shaver, Assigned: Scott Collins)

Tracking

Trunk
mozilla0.9
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

So that we can do:
nsXPIDLString foo = getter_Copies(strdup("foo"));
obj->InOutMethod(getter_InOut(foo));

It should assert (ideally not compile, maybe we can do that with New Strings) if
I try:

nsXPIDLString foo = getter_Shares("foo");
obj->InOutMethod(getter_InOut(foo));
(Assignee)

Comment 1

18 years ago
Hmmm...
Status: NEW → ASSIGNED

Updated

18 years ago
QA Contact: leger → kandrot
(Assignee)

Comment 2

18 years ago
I'm folding XPIDL strings into the main stream string classes, this will cease
to be an issue at that time, at which point, I'll mark this bug FIXED.
Component: XPCOM → String
Summary: need getter_InOut for XPIDL inout string params → [RFE] need getter_InOut for XPIDL inout string params
Target Milestone: --- → mozilla0.9
(Assignee)

Updated

18 years ago
Severity: normal → enhancement
Summary: [RFE] need getter_InOut for XPIDL inout string params → need getter_InOut for XPIDL inout string params
(Assignee)

Updated

18 years ago
Depends on: 53065
(Assignee)

Comment 3

18 years ago
|nsXPIDL[C]String| is really like an |auto_ptr| for strings.  We're going to
merge that functionality into the shared buffer implementation described in bug
#53065.  Eventually, that implementation will replace |ns[C]String| for all
clients in mozilla.
(Assignee)

Comment 4

18 years ago
bug #53065 already requires that the new default string, |nsCommon[C]String|,
implment |nsXPIDL[C]String| functionality, including being re-bindable (the
primary characteristic of an in/out parameter).  That was how this functionality
was to be merged.  Therefore, this bug is now a dup.


*** This bug has been marked as a duplicate of 53065 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

18 years ago
Blocks: 28221
(Assignee)

Updated

18 years ago
No longer depends on: 53065
You need to log in before you can comment on or make changes to this bug.