SVG images that specify width or height in em are rendered at a bad size

VERIFIED DUPLICATE of bug 305859

Status

()

defect
VERIFIED DUPLICATE of bug 305859
12 years ago
12 years ago

People

(Reporter: eric-bugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8

I want an SVG image that will scale with everything else when I resize the font, so its size should be specified in em.  Unfortunately all SVG images whose size are specified in terms of em or ex end up 0 size.

Reproducible: Always

Steps to Reproduce:
1.Load the specified URL
2.Note how it appears to be blank
3.View source and see how it ought to have an image thats 8.3em on a side.
Actual Results:  
Blank page

Expected Results:  
A small image that's about 8.3 lines of text high and the same distance wide.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102809 Minefield/3.0a9pre

I do see a shape, a square divided in 9 squares with 5 balls in it, but indeed not in Firefox 2.0.0.8, so I think this was fixed on trunk. Trunk builds:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Indeed fixed between 1 April and 1 July of this year. Resolving WORKSFORME.
Please reopen if you don't see it on Linux trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 305859
Reporter

Comment 3

12 years ago
Thanks.  :-)  I don't really have the patience or desire to install experimental builds on my box just to solve this problem.  So I'll wait for it to make it into Fedora.
Status: RESOLVED → VERIFIED
Component: General → SVG
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.