Patch for Bug 345711 Causes Multiple Active Tabs with Tab Mix Plus Dev Version for Trunk

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: olrrm2020, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007102617 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007102617 Minefield/3.0a9pre

With MR Tech Local Install 5.3.2.6 and Tab Mix Plus Dev-Build 0.3.6.0.070923 installed in a new profile and using Build Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007102617 Minefield/3.0a9pre (Bug 345711 checked in), you will have multiple tabs active with the address of the first tab showing in the urlbar. Once you switch away from the first tab, you are unable to switch back to it. Disabling TMP will fix the problem. Disabling Local Install usually will correct it, but I have had occasions where I have seen the problem with Local Install disabled. It is not as repeatable as with both TMP and Local Install installed.

Reproducible: Sometimes

Steps to Reproduce:
1. Start with a new profile. Open 2 tabs.
2. Install MR Tech Local Install 5.3.2.6 and Tab Mix Plus Dev-Build 0.3.6.0.070923. Use Minefield's session restore when prompted.
3. Restart using Restart Minefield button in Add-ons Manager.
4. On reopening, if you click on the second tab, it will become active along with the first tab. You cannot switch back to the first tab. The address of the first tab will remain in the urlbar
5. If the problem is not there, try disabling and then re-enabling TMP using the Restart button during this process.
6. #5 appears to be very consistent if the problem does not show on the restart after initially installing TMP.
Actual Results:  
You have multiple active tabs with the first tab address appearing in the urlbar regardless of the tab you are viewing. Also, once you switch away from the first tab you cannot switch back when clicking on the tab.

Expected Results:  
You should have only one active tab. When switching between tabs, the urlbar will show the address of the tab you are viewing. You can switch back to the first tab when clicking on its tab.

I posted this (http://tmp.garyr.net/forum/viewtopic.php?p=22148#22148) in the TMP forum. It has example pictures of the problem and the build. The prior build (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007102613 Minefield/3.0a9pre ID:2007102613) does not have the problem.
Blocks: 345711
Component: Tabbed Browser → XBL
Product: Firefox → Core
QA Contact: tabbed.browser → xbl
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
Keywords: regression

Comment 1

11 years ago
I'm seeing the same thing with only TabMixPlus installed, no MrTechLocalInstall; current builds:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102904 Minefield/3.0a9pre ID:2007102904
Tab Mix Plus 0.3.6.0.070923
(Reporter)

Comment 2

11 years ago
A potential patch of TMP is available here: http://tmp.garyr.net/forum/viewtopic.php?p=22163#22163

It appears to work for me in both the Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre)Gecko/2007102617 Minefield/3.0a9pre build and today's nightly, Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007103004 Minefield/3.0a9pre ID:2007103004.

(It also fixes the issue where you could not dnd tabs if you had selected the Native style of drop indicator instead of the Built-in style.)
That's not a patch; that's an entire extension version.  What was actually changed?

Knowing that would help a lot in terms of fixing the underlying XBL issue here.
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> That's not a patch; that's an entire extension version.  What was actually
> changed?
> 
> Knowing that would help a lot in terms of fixing the underlying XBL issue here.
> 

Yes, it is an "entire" version. Yes, it appears to fix whatever the patch for Bug 345711 "broke". You have to ask the writer of TMP for what he did to "fix" his extension to account for whatever the patch affected. Did you follow the link in Comment 2? That is to the writer of TMP's site.

Sorry I could not be of more help.
onemen.one@gmail.com, do you happen to know what's up with this bug?
Do you see any errors in the JS console with the non-working version?

Comment 7

11 years ago
The changes in TMP was in setup.js i moved the call to function TMP_beforALL() and TMP_beforStartup() into the tabbrowser constructor (see tabmix_3.xml file)
(Reporter)

Comment 8

11 years ago
(In reply to comment #6)
> Do you see any errors in the JS console with the non-working version?
> 

I get this upon starting the browser:

Error: uncaught exception: [Exception... "Index or size is negative or greater than the allowed amount"  code: "1" nsresult: "0x80530001 (NS_ERROR_DOM_INDEX_SIZE_ERR)"  location: "chrome://browser/content/tabbrowser.xml Line: 219"]

using the older version TMP 0.3.6.0.070923. The 0.3.6.0.071030 version yields no error.
onemen.one@gmail.com, what's the actual effect of that change?  Where did those functions run from before?  Why did they break where they were?

One issue that's come up is that now we don't attach the binding until right before firing the constructor, which means that if you create and insert a node in a constructor, the node's binding won't be attached until the constructor finishes executing (since we don't do nested constructor invocations).  Is that the issue you ran into?
FWIW, i have a patch that fixes a number of issues, still testing which bugs it actually fixes.
Should be fixed by patch in bug 401463, please reopen if it's not.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.