Closed Bug 401679 Opened 12 years ago Closed 10 years ago

Firefox takes 100% CPU when processing some page

Categories

(Firefox :: General, defect)

2.0 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mykaul, Unassigned)

References

()

Details

(Keywords: perf, Whiteboard: [CLOSEME 2010-07-30])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

The page is http://www.ynet.co.il/articles/0,7340,L-3465625,00.html

The stack from process explorer:
ntkrnlpa.exe+0x69e3f
firefox.exe!nsPrintSettings::GetPrintPageDelay+0x55e9e
firefox.exe!nsPrintSettings::GetPrintPageDelay+0x73e22
firefox.exe!DeviceContextImpl::AbortDocument+0x60a16
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x4df3f
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x4dd6c
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x4dc65
firefox.exe!DeviceContextImpl::AbortDocument+0x60a16
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x424b9
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x422a6
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x42109
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x41184
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x40a5e
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x3f969
firefox.exe!DeviceContextImpl::AbortDocument+0x5fc97
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x41cc3
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x40fa3
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x40a5e
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x3f969
firefox.exe!nsPrintSettings::GetPrintPageDelay+0x753fa
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x3e882
firefox.exe!nsPrintSettings::GetPrintPageDelay+0x753fa
firefox.exe!Java_netscape_javascript_JSObject_initClass+0x3d554


Reproducible: Always

Steps to Reproduce:
1. Go to the URL mentioned above

Actual Results:  
Firefox seems to be consuming 100% CPU

Expected Results:  
Don't consume so much resources.
Confirming with Firefox 3.5 RC1 but I think the main problem here is not the (almost) 100% CPU, which might be expected since it is a long page with ~2000 comments, but the lack of application responsiveness for some seconds when the page loads : 
Trying to switch between tabs quickly during the page load is not possible several times during the page load for a second or two.

Is it an interruptible reflow problem (bug 67752)?
Forgot to mention that this bug happens (both 100% CPU, and freezes during page load) even when I use Adblock Plus to block all the flash ads on this page .
Doesn't seem so bad in the "Seamonkey" "nightly" "trunk" suite browser also running Adblock extension.

Version:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2pre ID:20090903004335
Just wanted to add that the above was to show it might be Firefox specific, as opposed to gecko related.
To have much hope of attention, need a reduced testcase from the URL per http://quality.mozilla.org/documents-home/bugs-docs/bug-triaging-guidelines/minimal-test-cases
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch
Cannot reproduce on 4.0b1 - closing.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.