background image & bgcolor don't appear when set by javascript

VERIFIED DUPLICATE of bug 39642

Status

()

Core
DOM
P3
critical
VERIFIED DUPLICATE of bug 39642
18 years ago
17 years ago

People

(Reporter: ckritzer (gone), Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Overview: When setting the background image using javascript to access the DOM
HTMLBodyElement.background attribute, the image does not appear.

Steps to reproduce:
1. Launch build
2. Load attached testcase

Actual Results: No image appears

Expected Results: The image should appear in the background

Platforms Tested:
- MacOS9 2000-05-22-08-M16 Commercial build
- Linux6 2000-05-22-08-M16 Commercial build
- Win98  2000-05-22-08-M16 Commercial build

Additional Info:  None at this time.
(Reporter)

Comment 1

18 years ago
Setting self to QAContact
QA Contact: gerardok → ckritzer
(Reporter)

Comment 2

18 years ago
Created attachment 8993 [details]
testcase showing background not being set
(Reporter)

Comment 3

18 years ago
Created attachment 8994 [details]
background image for testcase
(Reporter)

Comment 4

18 years ago
jst, if this should be a separate bug, please clue me & I'll take care of it.  
The second item listed in these comments is similar in result, but might be 
different on your end <grin>.

The background color is also not being set by javascript.  See attached 
testcase.
(Reporter)

Comment 5

18 years ago
Created attachment 9189 [details]
testcase showing no background color being set via javascript
(Reporter)

Comment 6

18 years ago
Updating summary from:
 - "background image does not appear when set by javascript"
to:
 - "background image & bgcolor don't appear when set by javascript"

Nominating for nsbeta2 based on:
- high visibility
Keywords: nsbeta2
Summary: background image does not appear when set by javascript → background image & bgcolor don't appear when set by javascript
(Reporter)

Comment 7

18 years ago
Additional Note:
After reviewing the bug w/Vidur, I've added bgcolor to the bug for ease of 
tracking.
As of the 2000-05-30-20 builds (Win, Mac, Linux) the background appears to be 
working correctly, but bgcolor is not...
Setting to [nsbeta2+].
Whiteboard: [nsbeta2+]
(Reporter)

Comment 9

18 years ago

*** This bug has been marked as a duplicate of 39642 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

18 years ago
Marking VERIFED DUPLICATE on:
 - MacOS9 2000-06-01-20-M16 Commercial Build
 - Linux6 2000-06-01-20-M16 Commercial Build
 - Win98  2000-06-01-21-M16 Commercial Build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.