Canvas miterLimit ignored on axis-aligned corners

RESOLVED FIXED

Status

()

Core
Graphics
P3
normal
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Philip Taylor, Assigned: vlad)

Tracking

unspecified
x86
Linux
Points:
---
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Opera/9.24 (X11; Linux i686; U; en)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007103004 Minefield/3.0a9pre

When drawing a stroked box with lineJoin = 'miter' and small miterLimit, the corners should be bevelled (because the miters would exceed the limit).

Reproducible: Always

Steps to Reproduce:
See URL.

Actual Results:  
The corners are bevelled if the box is rotated a tiny bit, but are incorrect if it isn't.

Expected Results:  
The corners should be bevelled, independent of any transformations.

Worked correctly in FF2. (I assume this is a general Cairo issue, not specifically canvas.)
Current hypothesis is that this bug is causing the test_2d.line.miter.rightangle.html and test_2d.line.miter.lineedge.html tests in content/canvas/test to fail on Linux and Windows, but not Mac.  Confirming based on the difference in platrform behavior, which does in fact seem like a cairo bug.
Status: UNCONFIRMED → NEW
Component: GFX → GFX: Thebes
Ever confirmed: true
Flags: blocking1.9?
QA Contact: general → thebes

Comment 2

11 years ago
Vlad/Pav thoughts on this?

Comment 3

11 years ago
Vlad/pav moving to blocking P3.  If you disagree adjust...
Flags: blocking1.9? → blocking1.9+
Priority: -- → P3
Assignee: nobody → vladimir
Yay, fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.