Last Comment Bug 401806 - support building with dtrace enabled on Mac OS X
: support building with dtrace enabled on Mac OS X
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Mac OS X
: -- enhancement (vote)
: mozilla1.9beta1
Assigned To: Ryan Flint [:rflint] (ping via IRC for reviews)
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 17:37 PDT by Myk Melez [:myk] [@mykmelez]
Modified: 2007-11-01 23:36 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.12 KB, patch)
2007-10-31 14:43 PDT, Ryan Flint [:rflint] (ping via IRC for reviews)
no flags Details | Diff | Splinter Review
The right patch (4.25 KB, patch)
2007-10-31 14:47 PDT, Ryan Flint [:rflint] (ping via IRC for reviews)
ted: review+
mtschrep: approvalM9+
Details | Diff | Splinter Review

Description Myk Melez [:myk] [@mykmelez] 2007-10-30 17:37:25 PDT
Now that Mac OS X 10.5 includes support for dtrace, we should support building with dtrace enabled on that OS.  According to Adam Leventhal in a blog post <http://blogs.sun.com/ahl/entry/dtrace_firefox_leopard>, it's not too tricky, and he has a patch.  Ryan Flint also has a patch <http://screwedbydesign.com/mozilla/dtracemac.diff>.
Comment 1 Adam Leventhal 2007-10-30 18:12:57 PDT
Ryan's patch looks good; just two comments:

It seems like it would be a good idea to change the polarity of the condition (if !MACOSX) since FreeBSD and other ports are, I'd argue, likely to be in the model of Solaris _and_ Mac OS X will hopefully implement -G at least as a no-op (apple bug <rdar://problem/5566030>).

I think it's worth noting in the change to the provider D file that it's a work around for apple's bugs: <rdar://problem/5194316> <rdar://problem/5565198>
Comment 2 Ryan Flint [:rflint] (ping via IRC for reviews) 2007-10-31 14:43:43 PDT
Created attachment 286883 [details] [diff] [review]
Patch

Same patch with Adam's comments addressed.
Comment 3 Ryan Flint [:rflint] (ping via IRC for reviews) 2007-10-31 14:47:05 PDT
Created attachment 286886 [details] [diff] [review]
The right patch

Bah, It'd probably be helpful if I gave these unique names before attaching them.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2007-11-01 11:11:24 PDT
Comment on attachment 286886 [details] [diff] [review]
The right patch

I can't say I fully understand how DTrace works, but this just comments out the calls to dtrace from the build process.  What are we losing from that?
Comment 5 Brian Crowder 2007-11-01 13:32:21 PDT
The calls eliminated are superfluous on Leopard (needed by Solaris)
Comment 6 Ryan Flint [:rflint] (ping via IRC for reviews) 2007-11-01 19:19:29 PDT
Comment on attachment 286886 [details] [diff] [review]
The right patch

Drivers: this is a nearly zero risk patch (only changes code built with --enable-dtrace) that will allow our developers and others on Leopard to utilize DTrace - which is immensely useful for our ongoing performance efforts.
Comment 7 Mike Schroepfer 2007-11-01 19:33:19 PDT
Comment on attachment 286886 [details] [diff] [review]
The right patch

a+ as we don't ship with --enable-dtrace by default (thus NPOTDB) but useful for devs anyway
Comment 8 Reed Loden [:reed] (use needinfo?) 2007-11-01 23:36:59 PDT
Checking in config/rules.mk;
/cvsroot/mozilla/config/rules.mk,v  <--  rules.mk
new revision: 3.576; previous revision: 3.575
done
Checking in js/src/Makefile.in;
/cvsroot/mozilla/js/src/Makefile.in,v  <--  Makefile.in
new revision: 3.113; previous revision: 3.112
done
Checking in js/src/javascript-trace.d;
/cvsroot/mozilla/js/src/javascript-trace.d,v  <--  javascript-trace.d
new revision: 3.2; previous revision: 3.1
done

Note You need to log in before you can comment on or make changes to this bug.