Closed Bug 401872 Opened 14 years ago Closed 14 years ago

Newlines (\n) in description of meeting requests from Outlook are ignored

Categories

(Calendar :: Lightning Only, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 265971

People

(Reporter: richard, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Lightning 0.7

When I receive meeting requests from Outlook (vcalendar format) where the description contains newlines (\n) these are ignored by Lightning. All I see is one long line for the description.

Reproducible: Always

Steps to Reproduce:
1. Open meeting request from Outlook containing \n in the description
Actual Results:  
The description is shown as one line of text.

Expected Results:  
The description should contain multiple lines as indicated by the \n strings.
I can confirm this and I was already working on a patch, but it seems this bug derives from the way the HTML formatter works, that is, quite poorly (for instance, HTTP links are shown as plain text).

If it's OK, I could take this bug together with bug 387863, which is on a similar issue and involving the same component.
I'm not sure what the rules are for merging bugs, but bug 387863 is about not displaying the END TIME which is quite a different issue. If you can fix it with one patch, that's great though.
This bug is similar to Bug 265971.
Definitely a duplicate of bug 265971, which I'm working on already.

Anyone to dup this?
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265971
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.