Google Groups missing most (12/14 articles) of mda.firefox thread

RESOLVED WONTFIX

Status

mozilla.org Graveyard
Server Operations
--
minor
RESOLVED WONTFIX
10 years ago
2 years ago

People

(Reporter: myk, Assigned: justdave)

Tracking

Details

(Reporter)

Description

10 years ago
On 2007 May 10 I posted an article to mda.firefox titled "site-specific sidebars/toolbars".  It's a text/plain article with no attachments, and it has the following URL:

news://news.mozilla.org:119/Yrmdnb8uQ917nt7bnZ2dnUVZ_oqmnZ2d@mozilla.org

Thirteen subsequent articles were posted to the thread, but only the last two appear on Google Groups:

http://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/8cc53972ed0e0585/

Seems like they should all appear.
Last time we had an issue similar to this, there was something stuck on one of Google's edge servers.  I've sent them a note to see if they can look into it.
Assignee: server-ops → justdave
Whiteboard: waiting for Google
I failed to notice the dates when I first looked at this...  the messages are from back in May, and Google no longer has any logs going back that far to see what happened.  There's no evidence that the problem is still happening on new messages.

I've asked if they can pull the missing messages over, we'll see what they're willing to do.  I know from past experience we can't re-inject them from Giganews' end because Google's edge servers will reject them for being too old.
Last status is Google says they have no mechanism in place for pulling the existing messages, but that if Giganews flags them as available again they will indeed pick them up, despite the dates on them.  I've asked Giganews if they have a way to do that, waiting on them now.
Whiteboard: waiting for Google → waiting for Giganews
and back to Google...  Giganews did flag the messages as available, and their logs claim Google picked them up again, but they haven't show up on Google yet.
Whiteboard: waiting for Giganews → waiting for Google
So they obviously haven't shown up on Google yet...  They're digging around to see if they can track down what happened to them, but I'm not sure how much further progress we'll make if they don't find them this time.  How bad do we want this?
(Reporter)

Comment 6

10 years ago
It would certainly be useful to see this messages in Google Groups.  I recently tried to point someone at that thread and had to talk them through finding it in a desktop news reader since it wasn't in Google Groups.

Nevertheless, it wouldn't kill me not to have them.  It's certainly not a blocker.  But it concerns me that Google Groups is losing messages.  If it lost these, it might be losing others.  And it seems like that's an issue it would be important to address, to figure out what's going on and make sure it doesn't happen again.
So word back from Google is the re-sent messages were rejected at the incoming servers because they were dated more than 10 days in the past.  They seem generally unwilling to do anything about it because it would require writing code to override the date filters in specific cases to get the messages pulled in.
So yeah, word on this is we're getting nowhere.  We made a good attempt to get the messages re-imported and it didn't work.  Google thinks at this point that succeeding in getting them imported will require them to write code, which they don't really sound willing to do.  I've opened bug 403970 for our next step in trying to preserve history better.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Whiteboard: waiting for Google
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.