Crash on http://www.howtoforge.com/ [Xerror calls exit on 'BadAlloc (insufficient resources for operation)']

RESOLVED DUPLICATE of bug 369971

Status

()

Core
General
--
critical
RESOLVED DUPLICATE of bug 369971
10 years ago
3 years ago

People

(Reporter: Arthur, Unassigned)

Tracking

({crash, pp, testcase})

1.8 Branch
x86
Linux
crash, pp, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
2.0.0.9 crashes without further ado on the given URL. No talkback report, no console output.
(Reporter)

Comment 1

10 years ago
Crashes on http://www.howtoforge.com/ and other URLs on that domain as well.
Summary: Crash (no talkback report generated) → Crash on http://www.howtoforge.com/ (no talkback report generated)
(Reporter)

Comment 2

10 years ago
Created attachment 287103 [details]
Testcase crashing FF 2.0.0.9. Probably through external files.

This saved version of the index.html file crashes FF 2.0.0.9 as well. Could still be triggered through external media though. I'm not sure whether I'll find the time to make the testcase any smaller.
(Reporter)

Updated

10 years ago
Keywords: crash, stackwanted
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Comment 4

10 years ago
WFM, Firefox 2.0.0.9 on Linux

Arthur, does the crash occur also in Firefox Safe Mode?
(it temporarily disables add-ons and themes, this test will help us narrow
down the cause of the problem) --  See http://kb.mozillazine.org/Safe_Mode
(Reporter)

Comment 5

10 years ago
Crashes in safe-mode as well. Doesn't crash with (vanilla) 2.0.0.9 on Ubuntu Gutsy. The machine it crashes on runs Debian Sarge (also vanilla 2.0.0.9). In safe mode at least an error message is displayed on the console:

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 17639 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
I can't crash Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9pre) Gecko/20071104 BonEcho/2.0.0.9pre (debug) with either the attached testcase or by visiting http://www.howtoforge.com/ .

I do notice that the site uses a lot of Flash ads, though, which may be related. Which version of the flash player do you have installed? Does this work for you in 2.0.0.8 or another earlier version of Firefox?
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: 2.0 Branch → 1.8 Branch
Oh, I suppose this could be Linux specific, I didn't notice the OS field initially.
(Reporter)

Comment 8

10 years ago
Does crash in 2.0.0.1 and 2.0.0.8 on the same machine as well. Seems to be similar to bug 321581 where the second image also crashes Firefox on the Sarge machine but not on the Gutsy one. X.org version on Sarge machine is:

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Date: 07 October 2005

On the Gutsy computer:

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Date: 29 September 2007

(I'd say that's a 7.2.)
(Reporter)

Comment 9

10 years ago
(The ubuntu one is rather a 7.3, sorry)
I think you're on the right track, it's not a crash but XError calls exit...
Would still be nice if you could get the stack trace for that exit call.
Make sure you have the 'gdb' package installed and then start firefox from
a terminal window like so:
firefox -g -d gdb

At the gdb prompt, enter:
handle SIG33 noprint nostop
run --sync

then interrupt it with a CTRL+C in the terminal window and run the
following two gdb commands:
break exit
continue

then make firefox "crash" as before (which should hit the breakpoint
in exit), then enter the gdb command:
backtrace

and paste the output from that command here.  Thanks.
Keywords: pp
Summary: Crash on http://www.howtoforge.com/ (no talkback report generated) → Crash on http://www.howtoforge.com/ [Xerror calls exit on 'BadAlloc (insufficient resources for operation)']
(Reporter)

Comment 11

10 years ago
I hope that helps:

(gdb) backtrace
#0  0xb740a136 in exit () from /lib/tls/libc.so.6
#1  0xb7a67b41 in _gdk_windowing_exit () from /usr/lib/libgdk-x11-2.0.so.0
#2  0xb7851454 in _XError () from /usr/X11R6/lib/libX11.so.6
#3  0xb784f9b3 in _XReply () from /usr/X11R6/lib/libX11.so.6
#4  0xb784ac14 in XSync () from /usr/X11R6/lib/libX11.so.6
#5  0xb784acd5 in XSync () from /usr/X11R6/lib/libX11.so.6
#6  0xb78313d5 in XCreatePixmap () from /usr/X11R6/lib/libX11.so.6
#7  0xb7a685a5 in gdk_pixmap_new () from /usr/lib/libgdk-x11-2.0.so.0
#8  0x082056b6 in XmlInitUnknownEncodingNS ()
#9  0x08202887 in XmlInitUnknownEncodingNS ()
#10 0x082049e0 in XmlInitUnknownEncodingNS ()
#11 0x087daf55 in nsBaseHashtableET<nsStringHashKey, nsCOMPtr<nsIVariant> >::nsBaseHashtableET ()
#12 0x0821bb30 in XmlInitUnknownEncodingNS ()
#13 0x087f74af in MOZ_PNG_push_fill_buffer ()
#14 0x087f662e in MOZ_PNG_zfree ()
#15 0x087f63c2 in MOZ_PNG_zfree ()
#16 0x087f634f in MOZ_PNG_zfree ()
#17 0x0821b495 in XmlInitUnknownEncodingNS ()
#18 0xb7e31c0b in nsInputStreamTee::WriteSegmentFun () from ./libxpcom_core.so
#19 0xb7e34e47 in nsPipeInputStream::OnInputException () from ./libxpcom_core.so
#20 0xb7e31e42 in nsInputStreamTee::WriteSegmentFun () from ./libxpcom_core.so
#21 0x0821b514 in XmlInitUnknownEncodingNS ()
#22 0x0821a091 in XmlInitUnknownEncodingNS ()
#23 0x082188a7 in XmlInitUnknownEncodingNS ()
#24 0x0813bc67 in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable ()
#25 0x0817a8a7 in nsTHashtable<nsBaseHashtableET<nsStringHashKey, nsCOMPtr<nsIVariant> > >::~nsTHashtable ()
#26 0x0812b3b9 in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable ()
#27 0x0812b225 in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable ()
#28 0xb7e36a60 in nsInputStreamReadyEvent::EventHandler () from ./libxpcom_core.so
#29 0xb7e4e1bf in PL_HandleEvent () from ./libxpcom_core.so
#30 0xb7e4e112 in PL_ProcessPendingEvents () from ./libxpcom_core.so
#31 0xb7e4f7b4 in nsEventQueueImpl::CheckForDeactivation () from ./libxpcom_core.so
#32 0x0824c8f0 in XmlInitUnknownEncodingNS ()
#33 0xb792fdbf in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#34 0xb790a582 in g_main_depth () from /usr/lib/libglib-2.0.so.0
#35 0xb790b5f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0xb790b930 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0xb790bed3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---~
#38 0xb7bbcbb3 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#39 0x0824cb94 in XmlInitUnknownEncodingNS ()
#40 0x086ab46c in nsXPTCVariant::Init ()
#41 0x0807d279 in ?? ()
#42 0x08b58218 in ?? ()
#43 0x00000000 in ?? ()
#44 0x00000000 in ?? ()
#45 0x00000001 in ?? ()
#46 0x08842200 in _IO_stdin_used ()
#47 0xbfb38d98 in ?? ()
#48 0x08842200 in _IO_stdin_used ()
#49 0xbfb38d98 in ?? ()
#50 0x00000000 in ?? ()
#51 0x08842160 in _IO_stdin_used ()
#52 0xbfb38d94 in ?? ()
#53 0x08842160 in _IO_stdin_used ()
#54 0xbfb38d94 in ?? ()
#55 0x00000000 in ?? ()
#56 0x00000000 in ?? ()
#57 0x00000000 in ?? ()
#58 0x00000001 in ?? ()
#59 0x00000001 in ?? ()
#60 0xb7d7b6cc in ?? () from /lib/tls/libdl.so.2
#61 0x00000000 in ?? ()
#62 0x00000001 in ?? ()
#63 0x08a5ca30 in ?? ()
#64 0x08dd2bc8 in ?? ()
#65 0x00000000 in ?? ()
#66 0x00000001 in ?? ()
#67 0xbfb38dec in ?? ()
#68 0x08dd9be8 in ?? ()
#69 0xb73417c0 in ?? () from /usr/X11R6/lib/libICE.so.6
#70 0xb7382610 in ?? ()
#71 0x00000000 in ?? ()
#72 0x08d2c688 in ?? ()
#73 0xbfb38e68 in ?? ()
#74 0xb7d8d280 in ?? ()
#75 0x656e6966 in ?? ()
#76 0x08afb9d0 in ?? ()
#77 0xb73e5588 in ?? () from /lib/tls/libc.so.6
#78 0xb75ee7e8 in ?? ()
#79 0xb7d847e4 in pthread_mutex_lock () from /lib/tls/libpthread.so.0
---Type <return> to continue, or q <return> to quit---
#80 0x080794a3 in ?? ()
#81 0x00000002 in ?? ()
#82 0xbfb39124 in ?? ()
#83 0x08840c00 in _IO_stdin_used ()
#84 0xbfb390f8 in ?? ()
#85 0xb73f4974 in __libc_start_main () from /lib/tls/libc.so.6
#86 0xb73f4974 in __libc_start_main () from /lib/tls/libc.so.6
#87 0x08079401 in ?? ()

Comment 12

10 years ago
you need symbols for gecko too. --enable-debugger-info-modules or use your system's package manager to get symbols.
Whiteboard: DUPEME
(Reporter)

Comment 13

10 years ago
As this is a vanilla Firefox installation wouldn't I need a debug build? I don't think there's a debug symbols package for 2.0.0.9 in any of my repositories.

Are there any debug builds available now? I won't have time/disk resources for compiling my own build in the foreseeable future.
There's a (trunk) stack in bug 402542 for what I think is the same issue.
Keywords: stackwanted

Updated

10 years ago
Duplicate of this bug: 402542

Comment 16

10 years ago
Created attachment 287423 [details]
firefox_x_error_backtrace.txt

I am getting the same problem on Gentoo:
X.Org X Server 1.4.0
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.22-gentoo-r6 x86_64 
Current Operating System: Linux sol 2.6.23-gentoo #1 SMP PREEMPT Tue Oct 16 16:00:04 EEST 2007 x86_64
Build Date: 01 October 2007  06:50:33PM

Comment 17

10 years ago
Sane problem on current Debian unstable (package version 2.0.0.11-1).

Comment 18

9 years ago
Created attachment 299962 [details]
Backtrace

This is another backtrace for this problem. HTH.

Comment 19

9 years ago
Same problem on FF2.0.0.11, FF2.0.0.12, FF3b3 and Swiftfox 3.0b4pre-2

Running VectorLinux 5.9

strace gave this as last words:


[pid  4596] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
[pid  4596] rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
[pid  4596] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
[pid  4596] rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
[pid  4596] rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
[pid  4596] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
[pid  4596] exit_group(1)               = ?
Process 4595 resumed
Process 4596 detached
<... waitpid resumed> [{WIFEXITED(s) && WEXITSTATUS(s) == 1}], 0) = 4596
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
--- SIGCHLD (Child exited) @ 0 (0) ---
waitpid(-1, 0xbffad24c, WNOHANG)        = -1 ECHILD (No child processes)
sigreturn()                             = ? (mask now [])
rt_sigaction(SIGINT, {SIG_DFL}, {0x807b8d0, [], 0}, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
read(255, "", 408)                      = 0
exit_group(1)                           = ?
Process 4595 detached


Konsole output:

:$ ./firefox 
[NoScript] [NoScript] browserDOMWindow wrapped for external load interception
Plugger: Unable to find pluggerrc file!
The program 'firefox-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 18224 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
:$ echo $?
1


This only occurs on howtoforge :-s
The problem is with this image:
www.howtoforge.com/themes/htf_glass/images/bg_header_bottom_left15.png
It is 10.000 pixels wide (very ugly hack). It is a "bug" in the page
(I'll try to report it to howtoforge), but gecko shouldn't have any
problem displaing it (less than a megapixel).

Comment 21

9 years ago
I've got a WFM in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008032204 Minefield/3.0b5pre ID:2008032204 on Ubuntu Hardy.

I'm also looking at Launchpad bug #192885 for triage purposes. Could I get a confirmation of the status of this bug so I can let LP know the status?

Comment 22

9 years ago
I think I get this bug too with 
http://live.xbox.com/xweb/lib/images/MyXboxSkinImageSheet.gif
which is also 10000 pixels wide. 

My problem doesn't seem to be specifically related to Gecko as I can recreate it by loading that image in xpaint or using a short bit of code that calls Xcreatepixmap to make a 24 bit pixmap with a width of 8189 or larger.

Running on Ubuntu Hardy x64 with the Intel graphics driver, it goes away if I add  
option "AccelMethod" "XAA" 
to the device section of my xorg.conf

Comment 23

9 years ago
This went away completely for me once the patch, http://cgit.freedesktop.org/xorg/xserver/commit/?id=bc2d516f16d94c805b4dfa8e5b9eef40ff0cbe98  which fixes an overly restrictive check on pixmap width when exa is being used, was applied to the xserver. It seems to be applied to versions of the xorg xserver from 1.5 onwards but isn't in the 1.4 tree. I guess it's not really a firefox bug unless it can be prevented from dying when pixmap creation fails.

Comment 24

9 years ago
I still think it's weird that a site can crash a browser. But yes, it seems to be X related. The:
option "AccelMethod" "XAA" 
worked for me. Thnx.

I don't know if it's worth mentioning, but I also have Intel (integrated) graphics.
Keywords: testcase

Comment 25

8 years ago
Bug 369971 also mentions howtoforge, so I think this is a dup.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 369971

Updated

3 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.