Switching between designMode and contentEditable broken

VERIFIED FIXED in mozilla1.9beta1

Status

()

VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: peterv, Assigned: peterv)

Tracking

({regression})

Trunk
mozilla1.9beta1
regression
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

11 years ago
When turning on designMode on a page that has contentEditable elements the elements that don't have a contentEditable attribute can't be edited. This is a regression caused by the patch for bug 389350.
Flags: blocking1.9?
(Assignee)

Comment 1

11 years ago
Created attachment 287176 [details]
Testcase
(Assignee)

Comment 2

11 years ago
Created attachment 287177 [details] [diff] [review]
Untested patch
I've tested Peter's patch, and it does fix the case he pointed out. It also fixes the case that Karl pointed out here: https://bugzilla.mozilla.org/show_bug.cgi?id=389350#c21

Maybe we should push this into 1.9?
You mean M9? It should certainly block 1.9.
Yes, I mean M9; seeing as we were trying to get the fix for 389350 into M9, we may  as well put this patch in that fixes it properly.
Setting TM=M9.
Target Milestone: --- → mozilla1.9 M9
Comment on attachment 287177 [details] [diff] [review]
Untested patch

I've tested this patch, and it WFM, can you review this so we can push it into M9 please Brade?
Attachment #287177 - Flags: review?(brade)
Attachment #287177 - Flags: review?(brade) → superreview+
(Assignee)

Comment 8

11 years ago
Since I wrote the patch I don't think I should review, but Chris should be able to imho.
Comment on attachment 287177 [details] [diff] [review]
Untested patch

Looks good to me.
Attachment #287177 - Flags: review?(brade) → review+
Assignee: nobody → peterv
Comment on attachment 287177 [details] [diff] [review]
Untested patch

a=beltzner for M9
Attachment #287177 - Flags: approvalM9+
Attachment #287177 - Flags: approval1.9+
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite?
(Assignee)

Updated

11 years ago
Flags: blocking1.9?
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9a9pre) Gecko/2007110604 Minefield/3.0a9pre and on Tiger as well. I verified using the testcase attached to the bug. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.