Closed Bug 402317 Opened 14 years ago Closed 14 years ago

Web Application Generator

Categories

(Mozilla Labs :: Prism, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: sulleleven, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: 0.8

When launching prism.app, i am prompted to create a new webapp.  If i cancel, prism closes.  If i enter uri, name etc and submit, prism creates a new .app on my desktop or applications folder and immediately loads the uri in prism.app.  

Being more familiar with Webrunner and assuming the core still works the same (as described in the wiki- http://wiki.mozilla.org/WebRunner), i am confused as to why new .app files are being created as opposed to .webapp.  Also, the .app files seem to enclose prism.app itself in each instance.  This has the effect of not allowing me to open more than one prism app.  I receive a message:

"Close Prism : A copy of Prism is already open. Only one copy of Prism can be open at a time."

I should mention that I have deleted/uninstalled Webrunner prior to using the Prism 0.8 app.  So, .webapp that i created with Webrunner are properly being opened by Prism.  However, and this was a bug I had with last Webrunner release, whenever I try to open more than one .webapp, the second one launches the chrome window but without the containing uri... it is blank.  

I assume these are bugs but will need some clarification if not.  Do Prism webapps still require .webapp extension and should they still be built via the archived config .ini file (seems to still work that way)? 


Reproducible: Always

Steps to Reproduce:
1.Download Prism.app for Mac
2.Launch Prism.app
3.Generate new Prism app
4. Close Prism and Launch newly created prism app.
5. Launch a seconf Prism app concurrently.
Actual Results:  
Cannot load more than one Prism .app (seems to be wrapping Prism in each new app)
Cannot load more than one Prism .webapp (second instance is blank chrome window).

Expected Results:  
Should not have new .app files created.  They should be .webapp.  Prism should not be detecting each web app created as a new instance of Prism itself (right?).  User should not receive error messae to Close Prism because only one copy of Prism can be loaded at a time.
(In reply to comment #0)
> Being more familiar with Webrunner and assuming the core still works the same
> (as described in the wiki- http://wiki.mozilla.org/WebRunner), i am confused as
> to why new .app files are being created as opposed to .webapp.  Also, the .app
> files seem to enclose prism.app itself in each instance.

*.webapp files are bundles that define a web application and can be installed by Prism (and WebRunner) *if* the *.webapp file contains an ID in the webapp.ini (see http://wiki.mozilla.org/Prism/Bundle)

Both Prism and WebRunner will install a *.webapp bundle in the profile folder in the "webapps" subfolder. The installed web application is what Prism (and WebRunner) will point to when making shortcuts.

So this is not a bug. With Prism's ability to install web applications from its startup dialog *.webapps are not the only way to install web applications anymore. Future releases will allow users to add scripts, styles and icons from the Install dialog too.


>  This has the effect
> of not allowing me to open more than one prism app.  I receive a message:
> 
> "Close Prism : A copy of Prism is already open. Only one copy of Prism can be
> open at a time."
> 
This is a problem with XULRunner applications on Mac, not with only Prism. We are looking into it.


I am tempted to mark this bug invalid. You can open another bug (or convert this one) on the "opening multiple instances on Mac" bug
so with the XULRunner Mac issue... to confirm, does this translate to not being able to run more than one prism webapp at a time? If so, until that bug is fixed, running prism webapps on macs is limited to one at a time.  Correct?

I'd also like to confirm whether this XULRunner issue is causing both symptoms i described, 1) Error Message 2) Blank Chrome

Thanks.



Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.