Closed Bug 402478 Opened 14 years ago Closed 14 years ago

"Session restore" function needs regrooving

Categories

(Firefox :: Session Restore, defect)

2.0 Branch
x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 333907

People

(Reporter: orindaphobia, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Preface & Disclaimer:  I realize that this problem is probably already in this database. However, I really don't have time to exhaustively research and find the exact place to attach this bug report. I'd appreciate it if someone could take this and put it in the proper place, and register it as a vote for fixing/changing this behavior as well.

Problem: Since I normally don't close Firefox before shutting down Windows, I get the "session restore" message every time I start up Firefox after such a shutdown. I don't know if this is intentional behavior or not, but it is, frankly, a pain in the ass to have to respond to this alert each time I start it.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox.
2. Close Windows w/o closing Firefox.
3. Restart/start Windows, open Firefox.
Actual Results:  
"Session restore" dialog displays asking if I want to restore the previous session or not.


Expected Results:  
Nothing. (The previous version of Firefox, 1.0.something, did not exhibit this behavior.)

Here's my take on what SHOULD happen here:

I realize that not everyone uses Firefox the way I do; I fire it up, browse, shut Windows down without first closing the browser, and the next time expect to start from scratch. In other words, I don't care about "sessions" at all.

Other people care about sessions. So, to my way of thinking, the best of all possible worlds would be the following:

MAKE SESSION RESTORE AN OPTIONAL CHOICE.

Create an option, somewhere:

   ___ Retain session information and prompt for restore if browser quits unexpectedly?

(or some such; just a suggestion)

Those who want sessions retained and restored in case an "unexpected event" occurs would check this choice, in which case it would probably behave pretty much as it does now.

People like me would leave this option unchecked, in which case Firefox would not keep session information, and would not bug me if the browser was shut down by Windows without me first closing it and then subsequently restarted.

This raises the question, should a forced shutdown by Windows (shutting down the OS without first closing the browser) be considered an "unexpected event" at all? After all, this is clearly allowed behavior, and not uncommon among those who actually shut their computers down from time to time. But this is a subsidiary question that can be dealt with separately.
Version: unspecified → 2.0 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 333907
You need to log in before you can comment on or make changes to this bug.