Cycle collection crashes with Leak Monitor extension installed

RESOLVED FIXED in mozilla1.9beta1

Status

()

Core
XPConnect
P1
normal
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: peterv, Assigned: peterv)

Tracking

({crash, regression})

Trunk
mozilla1.9beta1
crash, regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

11 years ago
We're trying to trace a context without a global object. That context is created when the service something gets the service @dbaron.org/leak-monitor-service;1. The cycle collector should just deal.
This should be blocking M9, we want people to use that extension to help us track down leaks.
Flags: blocking1.9?
(Assignee)

Updated

11 years ago
Blocks: 401687
Status: NEW → ASSIGNED
Keywords: crash, regression
Priority: -- → P1
(Assignee)

Comment 2

11 years ago
Created attachment 287400 [details] [diff] [review]
v1 (diff -w)

This makes us not add contexts with null globalobjects to mClearedGlobalObjects so that when we look up global objects corresponding to contexts in TraceXPConnectRoots we only get a non-null globalobject if the context is in mClearedGlobalObjects.
Attachment #287400 - Flags: superreview?(jst)
Attachment #287400 - Flags: review?(jonas)
Anybody using cycle collector with trunk is overriding extension compatibility; it isn't even close to working for finding leaks anymore.
Er, anybody using *leak monitor* with trunk since cycle collector landed is ...
(Assignee)

Comment 5

11 years ago
This might be triggered by more than just Leak Monitor though. Also, wouldn't it make it harder to fix Leak Monitor so it works with the beta?
It might.  I'm just surprised people are using current leak monitor.

Updated

11 years ago
Attachment #287400 - Flags: superreview?(jst) → superreview+
Blocking, but agree with dbaron and don't think it should hold up beta unless there's a solid expectation that this indicates another potential crash in the cycle collector: peterv, is that what you're saying?
s/Blocking/I think this should block final,/ above
Yeah, discussed with peterv.  Marking as blocking.  Let's get this landed.  Also, sounds like we need to get leak monitor working in general.  Is there a bug for that?
Flags: blocking1.9? → blocking1.9+
(Assignee)

Comment 10

11 years ago
I think this is showing up as js_GetGCThingFlags crashes on breakpad: http://crash-stats.mozilla.com/report/list?range_unit=weeks&query_search=signature&query_type=contains&signature=js_GetGCThingFlags&query=js_GetGCThingFlags&range_value=1
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
FWIW, I wasn't using Leak Monitor when I started experiencing this crash, but it was enabled, since I have compatibility checking turned off.  There may be other folks in the same boat who aren't actually using the extension but still have it enabled.
You need to log in before you can comment on or make changes to this bug.