Change needed for ARM hardware platform for QNX (Photon) port

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: mfeil, Assigned: mfeil)

Tracking

({fixed1.8.1.12})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Photon; U; QNX x86pc; en-US; rv:1.8.1.5pre) Gecko/0000000000 BonEcho/2.0.0.5pre

The Javascript-to-native calling interface needs to be implemented for QNX Neutrino ARM targets. Without this most JS does not work.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

11 years ago
Created attachment 287417 [details] [diff] [review]
QNX-only proposed changes for ARM platform, 1.8 branch

The changes in this patch were made in a way so that non-QNX code is not affected.
Attachment #287417 - Flags: approval1.8.1.10?
Comment on attachment 287417 [details] [diff] [review]
QNX-only proposed changes for ARM platform, 1.8 branch

Please get appropriate reviews and land on trunk before asking for branch check-in approval.

Would also inspire more confidence if this were assigned to a person. Since you patched it that probably should be you.
Attachment #287417 - Flags: approval1.8.1.10?
(Assignee)

Updated

11 years ago
Attachment #287417 - Attachment description: QNX-only proposed changes for ARM platform → QNX-only proposed changes for ARM platform, 1.8 branch
(Assignee)

Comment 3

11 years ago
Created attachment 287887 [details] [diff] [review]
QNX-only proposed changes for ARM platform, TRUNK

For QNX JS->native calls
Attachment #287887 - Flags: review?(benjamin)
(Assignee)

Updated

11 years ago
Attachment #287417 - Flags: review?(benjamin)
Assignee: nobody → maxf
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

11 years ago
Comment on attachment 287417 [details] [diff] [review]
QNX-only proposed changes for ARM platform, 1.8 branch

I did not carefully review the assembly because I don't know ARM, so I'm trusting you to have it right.
Attachment #287417 - Flags: review?(benjamin) → review+

Updated

11 years ago
Attachment #287887 - Flags: review?(benjamin) → review+
(Assignee)

Comment 5

11 years ago
Landed on trunk, waiting for branch approval:

Checking in Makefile.in;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in,v  <--  Makefile.
in
new revision: 1.95; previous revision: 1.94
done
RCS file: /cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_nto_arm.
cpp,v
done
Checking in xptcinvoke_nto_arm.cpp;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_nto_arm.cpp,v  <--
  xptcinvoke_nto_arm.cpp
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_nto_arm.c
pp,v
done
Checking in xptcstubs_nto_arm.cpp;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_nto_arm.cpp,v  <--
 xptcstubs_nto_arm.cpp
initial revision: 1.1
Status: NEW → ASSIGNED
(Assignee)

Comment 6

11 years ago
Comment on attachment 287417 [details] [diff] [review]
QNX-only proposed changes for ARM platform, 1.8 branch

QNX needs this checked into the MOZILLA_1_8_BRANCH for Firefox 2.0-based browser.
Attachment #287417 - Flags: approval1.8.1.11?
branch status is handled through request flags and "fixed1.8.1.x" keywords, bug is fixed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Attachment #287417 - Flags: approval1.8.1.10?
Comment on attachment 287417 [details] [diff] [review]
QNX-only proposed changes for ARM platform, 1.8 branch

approved for 1.8.1.10, a=dveditz. We're building soon (tomorrow?) so actual landing might be in 1.8.1.11 depending on how soon you get to it.
Attachment #287417 - Flags: approval1.8.1.10? → approval1.8.1.10+
Comment on attachment 287417 [details] [diff] [review]
QNX-only proposed changes for ARM platform, 1.8 branch

Will have to wait for next time
Attachment #287417 - Flags: approval1.8.1.10+ → approval1.8.1.10-
Comment on attachment 287417 [details] [diff] [review]
QNX-only proposed changes for ARM platform, 1.8 branch

approved for 1.8.1.12, a=dveditz for release-drivers

Please land on the early side of the release so it doesn't miss the code-release window.
Attachment #287417 - Flags: approval1.8.1.12? → approval1.8.1.12+
(Assignee)

Comment 11

11 years ago
Checking in Makefile.in;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in,v  <--  Makefile.
in
new revision: 1.80.4.5; previous revision: 1.80.4.4
done
Checking in xptcinvoke_nto_arm.cpp;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_nto_arm.cpp,v  <--
  xptcinvoke_nto_arm.cpp
new revision: 1.1.4.1; previous revision: 1.1
done
Checking in xptcstubs_nto_arm.cpp;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_nto_arm.cpp,v  <--
 xptcstubs_nto_arm.cpp
new revision: 1.1.4.1; previous revision: 1.1
done
Keywords: fixed1.8.1.12
OS: Other → Neutrino
You need to log in before you can comment on or make changes to this bug.