Last Comment Bug 402706 - change names of new width keywords
: change names of new width keywords
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: ---
Assigned To: David Baron :dbaron: ⌚️UTC-7
:
:
Mentors:
Depends on:
Blocks: 311415
  Show dependency treegraph
 
Reported: 2007-11-06 06:59 PST by David Baron :dbaron: ⌚️UTC-7
Modified: 2008-01-04 09:05 PST (History)
7 users (show)
roc: blocking1.9+
jwalden+bmo: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (59.47 KB, patch)
2007-11-14 15:12 PST, David Baron :dbaron: ⌚️UTC-7
bzbarsky: review+
bzbarsky: superreview+
Details | Diff | Splinter Review

Description David Baron :dbaron: ⌚️UTC-7 2007-11-06 06:59:40 PST
In bug 311415 I added support for some new keywords on the width property.  The CSS WG just agreed to add them to css3-box, but changed the names (which I was never happy with anyway).  So we should change our -moz-prefixed names to match the new names, since we haven't shipped the -moz-prefixed names in any release yet.

-moz-intrinsic => -moz-max-content
-moz-min-intrinsic => -moz-min-content
-moz-fill => -moz-available
-moz-shrink-wrap => -moz-fit-content
Comment 1 David Baron :dbaron: ⌚️UTC-7 2007-11-14 15:12:21 PST
Created attachment 288753 [details] [diff] [review]
patch

I generated this patch by running

find . -type f -exec perl -pi /builds/trunk/working/subst.pl {} \;

in mozilla/layout, where subst.pl contained:

s/-moz-fill/-moz-available/g;
s/_moz_fill/_moz_available/g;
s/NS_STYLE_WIDTH_FILL/NS_STYLE_WIDTH_AVAILABLE/g;
s/-moz-intrinsic/-moz-max-content/g;
s/_moz_intrinsic/_moz_max_content/g;
s/NS_STYLE_WIDTH_INTRINSIC/NS_STYLE_WIDTH_MAX_CONTENT/g;
s/-moz-min-intrinsic/-moz-min-content/g;
s/_moz_min_intrinsic/_moz_min_content/g;
s/NS_STYLE_WIDTH_MIN_INTRINSIC/NS_STYLE_WIDTH_MIN_CONTENT/g;
s/-moz-shrink-wrap/-moz-fit-content/g;
s/_moz_shrink_wrap/_moz_fit_content/g;
s/NS_STYLE_WIDTH_SHRINK_WRAP/NS_STYLE_WIDTH_FIT_CONTENT/g;

and then I hand-edited:
layout/base/nsStyleConsts.h, to line up the whitespace
layout/style/nsCSSKeywordList.h, to put the lines back in alphabetical order
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2007-11-14 20:26:39 PST
Comment on attachment 288753 [details] [diff] [review]
patch

r+sr=bzbarsky
Comment 3 David Baron :dbaron: ⌚️UTC-7 2007-11-15 10:15:48 PST
Fix checked in to trunk.

Adding dev-doc-needed since we need to search-replace the docs on bug 311415 with this change.
Comment 5 Eric Shepherd [:sheppy] 2008-01-04 09:05:11 PST
I fixed one last place; marking this as complete.

Note You need to log in before you can comment on or make changes to this bug.