Periodically the bookmarks top level flyout menus go missing

VERIFIED FIXED in Firefox 3

Status

()

defect
VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: marcia, Assigned: enndeakin)

Tracking

({polish, regression})

Trunk
Firefox 3
All
macOS
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Seen using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.5; en-US; rv:1.9a9pre) Gecko/2007110615 Minefield/3.0a9pre. Also seen on Tiger.

STR: 
1. New profile
2. Customize Toolbar->Change to Icons and Text. Add a few icons to the toolbar
3. View Sidebar | Bookmarks
4. Open a new tab and go slashdot.org and add the RSS feed to bookmarks

Go to Bookmarks menu. Observe that you cannot see anything under organize bookmarks.
If I restart Firefox, I can see the flyout menus. Also, in this horked state I am still able to add bookmarks.
works for me on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007110616 Minefield/3.0a9pre - mac only error ?

Comment 3

12 years ago
works for me with 2007110615/fedora 6
During my testing I have also been able to see the items listed below Organize bookmarks in the menu, but the flyouts don't show anything.
Using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1 on Leopard, I hit this book again, but this time I did not change the toolbar to icons and text.
I have seen this fairly consistently when testing the beta on the Leopard PPC mac in the lab.
Summary: Bookmarks top level is missing its flyout menus → Periodically the bookmarks top level flyout menus go missing
Seeing this consistently when testing the Beta 2 candidate on 10.5, Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2. I also see it on 10.4 using the latest trunk nightly (2007121107). I first notice it on 10.5 right after I finished the toolbar customization set of tests.
confirmed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2pre) Gecko/2007121107 Minefield/3.0b2pre also no errors in the js console. 
some js errors i see with javascript.options.showInConsole set to true:

Error: aMenuPopup.getResultNode is not a function
Source File: chrome://browser/content/browser.js
Line: 5462

Error: this._self.getResultNode is not a function
Source File: chrome://browser/content/places/toolbar.xml
Line: 464

Error: t.updateChevron is not a function
Source File: chrome://browser/content/places/toolbar.xml
Line: 72
During testing of beta 3 I have seen this enough that it concerns me - it happens with the History File menu as well as the Bookmarks file menu using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3. I believe as I noted earlier each time I have seen it I had previously added some icons to the toolbar. This may be Leopard only, I will test extensively on Tiger and see if I can get it to repro there.
Flags: blocking-firefox3?
Here are exact STR using a new profile:

1. Customize toolbar and drag Print, Paste, New Tab and New Icon to toolbar. Also change to "Icons and Text."
2. Go to File Menu and Check under History and Bookmarks File menu items.

On my machine, nothing is listed History even though I have visited several sites. Under Bookmarks, nothing shows under Show All Bookmarks (Get Bookmarks Addons and Mozilla Firefox flyout menu have gone missing)
If it only happens after you add toolbar buttons, I don't think this is a blocker, as much as I agree that it can be a pain in the ass.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Keywords: polish, regression
From hendrix, a report from someone seeing a similar issue with Windows XP:

When ever some icons are moved  to tool bar functions of  file/edit/view/History/Bookmarks/Tools/help  become non functional Only navigation bar  and book marks tool bar appear.  customise also blanked. After shifting icons ietab and ieview  , had to close  Minefield and again restart.  to normalise. 

Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5pre) Gecko/2008032505 Minefield/3.0b5pre
From URL: http://hendrix.mozilla.org/
I'm seeing this occasionally too (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008041504 Minefield/3.0pre ID:2008041504). I noticed it most-recently while flipping through the menus trying to recreate the help menu crasher in bug 426499.

I had noticed this happening prior to the beta cycle and not so much during the betas. The other day was the first time I'd seen it in a couple of months (and not since).
this is most likely a dupe of bug 425446, is there any difference?
Whiteboard: DUPEME?
Assignee

Comment 16

11 years ago
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #317062 - Flags: review?(mano)
Comment on attachment 317062 [details] [diff] [review]
simple fix is to just not wrap the menubar on Mac since it can't be customized anyway

Seriously? *ugh*.

r=mano.
Attachment #317062 - Flags: review?(mano) → review+
Assignee

Comment 18

11 years ago
Attachment #317539 - Flags: review?(mano)
Assignee

Comment 19

11 years ago
Comment on attachment 317539 [details] [diff] [review]
include a test

This may also fix 425446
Attachment #317539 - Flags: approval1.9?
Comment on attachment 317539 [details] [diff] [review]
include a test

a1.9=beltzner
Attachment #317539 - Flags: approval1.9? → approval1.9+
Saw this today with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008042404 Minefield/3.0pre ID:2008042404 while experimenting with a java applet and clicking through the menus while Firefox was loading the applet and hangs for a while.

http://www.fc-prints.de/home/fotos-bestellen/im-browser.html

Sadly its not reproducible.
Hardware: Macintosh → All
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Assignee

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Marcia. I'm reluctant to attempt to verify this, as I was not able to reproduce it.  If you would, please verify with the lab machine you mentioned in comment #6.
Whiteboard: DUPEME?
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008043004 Minefield/3.0pre.
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 3
Blocks: 467209
Assignee

Updated

11 years ago
Flags: in-testsuite+
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.