Backslash (%5C) in image location treated differently in IE and firefox.

VERIFIED DUPLICATE of bug 64488

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 64488
11 years ago
11 years ago

People

(Reporter: aps, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20061201 Firefox/2.0.0.8 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20061201 Firefox/2.0.0.8 (Ubuntu-feisty)

Images locations like http://www.wmah.org/image%5Cmelbourne3.jpg sometimes have backslashes in the address, written %5C.  In IE the baskslash appears to be translated to a  a forwardslash (probably due to IE's dos heritage), so in the above example IE will grab the image http://www.wmah.org/image/melbourne3.jpg which works fine.  While this might be technically dubious behaviour on IE's behalf, it would be nice if firefox could replicate to make browsing websites like the one mentioned above more pleasant.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.wmah.org/
2. observe that images like http://www.wmah.org/image%5Cmelbourne3.jpg do not load.
Actual Results:  
Images like http://www.wmah.org/image%5Cmelbourne3.jpg don't load.

Expected Results:  
Images like http://www.wmah.org/image%5Cmelbourne3.jpg should be translated to http://www.wmah.org/image/melbourne3.jpg prior to loading.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 64488

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.