Closed Bug 402807 Opened 14 years ago Closed 14 years ago

Elements on Cyberpresse.ca are displaced to the left

Categories

(Core :: Layout, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla1.9beta4

People

(Reporter: chadwickgab+mozilla, Assigned: mats)

References

()

Details

(Keywords: regression, testcase)

Attachments

(5 files)

On Cyberpresse.ca the width of the template is to short some elements are overflowing like the menu. Look at following screen shots. Regression because it works on 1.8 branch but not on trunk.

Getting it with Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9a9pre) Gecko/2007110605 Minefield/3.0a9pre ID:2007110605
Flags: blocking1.9?
Attached image Correct layout
Attached image Incorrect layout
Finally it looks more like these elements are to much to the left.
Summary: Fixed width on Cyberpresse.ca is to small → Elements on Cyberpresse.ca are displaced to the left
Regression range for this is 2007-07-03-04 to 2007-07-04-04. Confirming bug to get more attention.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9? → blocking1.9+
Priority: -- → P3
Attached file testcase
It seems that the background-image of the page doesn't take it into account when the page has a scrollbar.
Attached patch reftestSplinter Review
Attachment #287818 - Flags: review?(roc)
Attachment #287818 - Attachment is patch: true
Attachment #287818 - Attachment mime type: application/octet-stream → text/plain
Severity: normal → minor
Severity: minor → normal
IMO this should be fixed for beta3 and in consequence it should get an P2 upgrade.
Regression from Mats' patch.
Assignee: nobody → mats.palmgren
RCS file: /cvsroot/mozilla/layout/reftests/bugs/402807-1.html,v
done
Checking in 402807-1.html;
/cvsroot/mozilla/layout/reftests/bugs/402807-1.html,v  <--  402807-1.html
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/layout/reftests/bugs/402807-1-ref.html,v
done
Checking in 402807-1-ref.html;
/cvsroot/mozilla/layout/reftests/bugs/402807-1-ref.html,v  <--  402807-1-ref.htm
l
initial revision: 1.1
done
Checking in reftest.list;
/cvsroot/mozilla/layout/reftests/bugs/reftest.list,v  <--  reftest.list
new revision: 1.290; previous revision: 1.289
done

I checked the reftest in as a known fail.
So as soon as this bug gets fixed, that has to be changed in the reftest.list file.
Flags: in-testsuite+
Blocks: 412314
Priority: P3 → P2
This also seems to be a problem at http://sierkbornemann.de/
Attached patch Patch rev. 1Splinter Review
Adjust for scrollbars.  This fixes all URLs, testcases and reftests.
Attachment #301040 - Flags: review?(sharparrow1)
Comment on attachment 301040 [details] [diff] [review]
Patch rev. 1

Eli is not active.
Attachment #301040 - Flags: superreview?(roc)
Attachment #301040 - Flags: review?(sharparrow1)
Attachment #301040 - Flags: review?(roc)
Attachment #301040 - Flags: superreview?(roc)
Attachment #301040 - Flags: superreview+
Attachment #301040 - Flags: review?(roc)
Attachment #301040 - Flags: review+
Mats, the patch can be checked in, right?
mozilla/layout/base/nsCSSRendering.cpp 	3.340

The reftest fails on Mac (qm-xserve01) so I commented it out.
Looking at the Tinderbox log I can't see any difference between
the TEST image and the REFERENCE image.  FWIW, the test works
on qm-win2k3-01 and qm-centos5-01 and it works fine locally
on Linux, so I'm not sure what the problem is on qm-xserve01.

-> FIXED
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: in-testsuite+ → in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta4
Verified on Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9b4pre) Gecko/2008020708 Minefield/3.0b4pre ID:2008020708
Status: RESOLVED → VERIFIED
The fix is verified/confirmed for Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9b4pre) Gecko/2008020708 Minefield/3.0b4pre.

The glitch with the false adjustment of the banner left-handed on http:/sierkbornemann.de/ is fixed now. Thanks! :-)
Uncommented the reftest in https://hg.mozilla.org/integration/mozilla-inbound/rev/5edb40fdafe5, since it doesn't seem to fail now (or fails intermittently and not very often, a thing which we now have better ways to deal with).
You need to log in before you can comment on or make changes to this bug.