browser hangs from applet with missing class-file or archive

RESOLVED DUPLICATE of bug 334117

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 334117
12 years ago
12 years ago

People

(Reporter: kherlak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.8) Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.8) Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/2.0.0.8

Whenever opening a page including an applet-tag referring to a missing or inaccessible class-file or jar-archive, Firefox hangs seemingly forever or until i kill it manually.

A workaround seems to be using the object-tag instead, which never seems to hang in this case or other situations where java seems to break the browser. Maybe applet-tags should use the same code as object-tags with java instead of the problematic one for applet-tags?

Reproducible: Always

Steps to Reproduce:
1.Create a html-document containing a single applet-tag referring to an unavailable class-name
2.Open it with Firefox by filesystem or via a web-server

Actual Results:  
Browser hangs

Expected Results:  
Applet shouldn't work but Browser should work normally
Reporter

Comment 1

12 years ago
Example with applet-tag (causes hang if a.class does not exist)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Crasher</title>
</head>
<body>
<applet class="a.class" width="50" height="50"></applet>
</body>
</html>

Example with object-tag (browser works normally)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Non-Crasher</title>
</head>
<body>
<object classid="java:a.class" codetype="application/java" width="50" height="50"></object>
</body>
</html>
What JRE version do you use?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 334117
You need to log in before you can comment on or make changes to this bug.