Closed Bug 402864 Opened 13 years ago Closed 10 years ago

Number failures in testsuite when running on linux

Categories

(Tamarin Graveyard :: Virtual Machine, defect, P4)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME
Q3 11 - Serrano

People

(Reporter: brbaker, Unassigned)

References

Details

(Keywords: flashplayer)

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: 

The following testcases are currently failing on linux:

FAILURES:
  ecma3/GlobalObject/e15_1_2_2_2.abc
  ecma3/GlobalObject/e15_1_2_6.abc
  ecma3/GlobalObject/e15_1_2_7.abc
  ecma3/TypeConversion/e9_3_1_3_rt.abc

Reproducible: Always

Steps to Reproduce:
1. cd tests
2. python runtests.py ecma3/GlobalObject/e15_1_2_2_2.as ecma3/GlobalObject/e15_1_2_6.as ecma3/GlobalObject/e15_1_2_7.as ecma3/TypeConversion/e9_3_1_3_rt.as
Actual Results:  
FAILURES:
  ecma3/GlobalObject/e15_1_2_2_2.abc : parseInt("123456789012345678") = 123456789012345680 FAILED! expected: 123456789012345700
  ecma3/GlobalObject/e15_1_2_6.abc : isNaN() = false FAILED! expected: true
  ecma3/GlobalObject/e15_1_2_7.abc : isFinite() = true FAILED! expected: false
  ecma3/TypeConversion/e9_3_1_3_rt.abc : parseInt("123456789012345678") = 123456789012345680 FAILED! expected: 123456789012345700
Attachment #287689 - Flags: review?(dschaffe)
Attachment #287689 - Flags: review?(dschaffe) → review+
Attachment #311237 - Attachment mime type: application/octet-stream → text/plaiin
Attachment #311237 - Attachment mime type: text/plaiin → text/plain
Attached patch patch (obsolete) — Splinter Review
e15_1_2_6.abc and e15_1_2_7.abc are passed now. So remove these two case from expected failure list.
Attachment #333510 - Flags: review?(dschaffe)
Attachment #333510 - Flags: review?(dschaffe) → review?(brbaker)
Comment on attachment 333510 [details] [diff] [review]
patch

This patch already checked in by cpeyer@adobe.com.
Attachment #333510 - Attachment is obsolete: true
Attachment #333510 - Flags: review?(brbaker)
Update expected failures to only fail in release and release_debugger builds. Debug and debug_debugger produce the proper results.

ecma3/GlobalObject/e15_1_2_2_2:parseInt\("123456789012345678"\)
ecma3/TypeConversion/e9_3_1_3_rt:parseInt\("123456789012345678"\)

Pushed change 648:89e096550269
Changeset 1241:9f9a9a0287a6 (Modify MathUtils bug #466272) seems to have fixed this issue. I have tested with gcc 4.1 and 4.2 and they are both passing. Removing the expected failures from the testconfig.txt

Pushed updated testconfig.txt 1245:a2dd51583214
Status: NEW → RESOLVED
Closed: 12 years ago
Depends on: 466272
Flags: wanted-flashplayer10+
Flags: in-testsuite+
Flags: flashplayer-triage+
Keywords: flashplayer
Resolution: --- → FIXED
Happening again, smells like heisenbugs
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
the release builds on linux are now failing for tests: 
ecma3/GlobalObject/e15_1_2_2_2:parseInt\("123456789012345678"\)
ecma3/TypeConversion/e9_3_1_3_rt:parseInt\("123456789012345678"\)

set tests to expectedfail for linux in acceptance testconfig.txt
Priority: -- → P3
Target Milestone: --- → flash10.1
Priority: P3 → P4
Target Milestone: flash10.1 → flash10.2
heisenbugs strikes again by disappearing. Looks like the change for bug# 546801 has removed this failure from linux release builds. Removing the expectedfail from the testconfig.

patch pushed to remove expectedfail:

tr-argo: 3757:fb2a6464082e
tr: 3923:fb2a6464082e

Marking as WORKSFORME
Status: REOPENED → RESOLVED
Closed: 12 years ago10 years ago
Resolution: --- → WORKSFORME
bulk verifying resolved !fixed issues
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.