Closed Bug 403060 Opened 14 years ago Closed 14 years ago

Crash in [@ CheckForTrailingTextFrameRecursive] when clicking on cell in Google Docs spreadsheet

Categories

(Core :: Layout, defect)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 403048

People

(Reporter: djst, Assigned: roc)

References

()

Details

(Keywords: crash, Whiteboard: [depends on 403048])

Crash Data

In today's build, go to docs.google.com and click on any cell in any spreadsheet. Crash!
http://crash-stats.mozilla.com/report/index/3c4af4e6-8e31-11dc-9b84-001a4bd46e84?date=2007-11-08-19

stack is:

0  	CheckForTrailingTextFrameRecursive(nsIFrame*, nsIFrame*)  	 mozilla/layout/base/nsCaret.cpp:621
1 	nsCaret::GetCaretFrameForNodeOffset(nsIContent*, int, nsFrameSelection::HINT, unsigned char, nsIFrame**, int*) 	mozilla/layout/base/nsCaret.cpp:647
2 	nsCaret::GetCaretFrame() 	mozilla/layout/base/nsCaret.cpp:413
3 	nsCaret::InvalidateOutsideCaret() 	mozilla/layout/base/nsCaret.cpp:422
4 	PresShell::ContentRemoved(nsIDocument*, nsIContent*, nsIContent*, int) 	mozilla/layout/base/nsPresShell.cpp:4620
5 	nsBindingManager::ContentRemoved(nsIDocument*, nsIContent*, nsIContent*, int) 	mozilla/content/xbl/src/nsBindingManager.cpp:1496
6 	nsNodeUtils::ContentRemoved(nsINode*, nsIContent*, int) 	mozilla/content/base/src/nsNodeUtils.cpp:165
7 	nsGenericElement::doRemoveChildAt(unsigned int, int, nsIContent*, nsIContent*, nsIDocument*, nsAttrAndChildArray&) 	mozilla/content/base/src/nsGenericElement.cpp:2756
8 	nsGenericElement::RemoveChildAt(unsigned int, int) 	mozilla/content/base/src/nsGenericElement.cpp:2689
9 	nsGenericElement::doRemoveChild(nsIDOMNode*, nsIContent*, nsIDocument*, nsIDOMNode**) 	mozilla/content/base/src/nsGenericElement.cpp:3319
10 	nsGenericElement::RemoveChild(nsIDOMNode*, nsIDOMNode**) 	mozilla/content/base/src/nsGenericElement.cpp:2889
Flags: blocking1.9?
Keywords: crash
Summary: Crash when clicking on cell in Google Docs spreadsheet → Crash in [@ CheckForTrailingTextFrameRecursive] when clicking on cell in Google Docs spreadsheet
Duplicate of this bug: 403093
I put a patch in bug 403048 that fixes this.
Assignee: nobody → roc
Whiteboard: [depends on 403048]
It's a duplicate.
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: blocking1.9?
Resolution: --- → DUPLICATE
Duplicate of bug: 403048
Crash Signature: [@ CheckForTrailingTextFrameRecursive]
You need to log in before you can comment on or make changes to this bug.