Autocomplete based on partial tag

VERIFIED DUPLICATE of bug 401660

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 401660
11 years ago
10 years ago

People

(Reporter: matp75zilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Firefox 3.0 a9 pre 20071106

With Firefox 2 :
Going to planet.mozilla.org
enjoy
return...
(repeat at will)

type p in the url bar
planet.mozilla.org is the first choice
cursor down and enter
it's done

Ok
With Firefox 3.0 (tested with 3.0 a9) 
go to planet.mozilla.org 
oh, I like it -> tag it blog
return often to planet.mozilla.org

ok, let's use this tag thing
so I type blog, planet.mozilla.org appears
cursor down + enter

let's repeat
I retype b
nothing appears (bug 392143 ? would be cool but I don't really care about the word blog, I wan't to go to the planet site.

Ok, try to be less lazy 
blo
still nothing
blog , the site just appears in the list !
this is not what's expected from a user point of view and it's a regression from firefox 2 because I have to type more letters to go to the same site.

Remarq : typing blo, the planet url is nowhere visible in the drop down list

Expected behaviour :

type b again 
firefox thinks (may be I'm typing blog, so I'm going to introduce the "blog" result in the list)
I type l (so bl)
probability that I will type blog increase
result planet.mozilla.org is upped

As I choose it, Firefox add more weight to this choice

next time I return, 
i just type b and planet.mozilla.org shows at the preferred choice because I probably wanted to type blog.
-> better than firefox 2 + happy user + other non firefox 3 users sees this and say whoo.

any chance to see this ?
any user seeing the new bar working like this ?






Reproducible: Always
(Reporter)

Comment 1

11 years ago
For the complete expected behaviour, I expect bug 395739 to land before.
This bug is about including the search result based on partial tag in the choices.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401660
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.