RTL word in LTR textbox not wrapped properly if immediately preceded by non-whitespace non-RTL character

RESOLVED DUPLICATE of bug 403455

Status

()

Core
Layout: Text
P2
normal
RESOLVED DUPLICATE of bug 403455
11 years ago
10 years ago

People

(Reporter: Uri Bernstein (Google), Assigned: roc)

Tracking

({regression, rtl, testcase})

Trunk
regression, rtl, testcase
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
In an LTR textbox (or block with white-space:-moz-pre-wrap), if an RTL word is immediately preceded by a non-whitespace, non-RTL character (e.g., a punctuation sign), the word does not wrap properly to the next line, but rather remains on the same line, causing a horizontal scrollbar to appear (or the text to overflow the block).

The above is also true for LTR in an RTL textbox.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9b2pre) Gecko/2007110804 Minefield/3.0b2pre
Flags: blocking1.9?
(Reporter)

Comment 1

11 years ago
Created attachment 287989 [details]
testcase
(Reporter)

Comment 2

11 years ago
Regressed between 2007-10-19 and 2007-10-20, probably by bug 393096.
Blocks: 393096
Assignee: nobody → roc
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
(Reporter)

Comment 3

11 years ago
Created attachment 288283 [details]
LTR testcase

This isn't strictly a bidi bug - the same problem happens whenever a word is split between frames, as this testcase demonstrates.
Turns out this is a dup of 403455 which I just filed with a patch :-)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403455

Comment 5

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.