Localized Extension description not maintained when the Add-on is disabled

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
In Bug 257155 we introduced the localization of extension description. This works when the Extension is active and enabled. 

When the Extension is disabled the description goes back to the en-US text.

Steps to reproduce:
- Use a Firefox 3 Beta 1 DE Build and install Adblock Plus
- The Extension Description is German 
- Disable the Extension - restart Firefox - and the Description goes back to english

So do we handle disabled extensions descriptions different then enabled ones ?
We actually added localized text for extensions a long time ago using pref getComplexValue which only works when an extension is enabled. Chances are what you are seeing is that adblock is using this instead of the new method. Can you provide a link to download adblock plus and I'll verify whether this is the case.
Yep, adblock plus has not added the localized text in its install.rdf that was added in Bug 257155.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

11 years ago
thanks, rob

I guess that this could maybe happen to a lot of extensions on Firefox 3.

Mark, Shaver: we maybe to evangelize this in general also for other extensions or ? shall i file a new bug for this ? 
Carsten - looks like Mossop (in bug 257155) added documentation to several places on MDC.

I'll make sure we get this highlighted in a blog post and whatever other ways we can get extension developer attention.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.