quirks mode: double underline (text-decoration) with font-weight: bold, and Arial

RESOLVED FIXED in mozilla8

Status

()

Core
Layout: Text
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: philippe (part-time), Unassigned)

Tracking

Trunk
mozilla8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 288094 [details]
test case

Bold words in links, or any span with text-decoration:underline, have a double underline.
This only happens when the Arial font is used.
This only happens in quirks mode.
(Reporter)

Comment 1

10 years ago
Created attachment 288095 [details]
screenshot of google page

Comment 2

10 years ago
Yes, I see this, too, on Linux and OS/2. In the testcase of attachment 288094 [details] both the "Arail" and "Lucida Grande" cases show it, at least when the font size is large enough (using Ctrl-+), the "Times" case doesn't.

In your screenshot I don't actually see a double underline, just an underline that is bold like the text. The underline thickness is actually a property of the font, and a bold font may well have a different value than a non-bold one (or another bold font).

But that doesn't explain why it only happens in quirks mode.
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)

> both the "Arail" and "Lucida Grande" cases show it, at least when the font size
You almost certainly don't have the 'Lucida Grande' font installed, as it is OS X only. The test case then defaults to Arail (which should be 'Arial', can't seem to spell that one right..).

And, yeah, the underline thickness is dependent on the font (and font-weight), but in this case, the whole text-run should have the same underline thickness (per the specs), as it does for most, if not all, fonts I have installed (didn't test them all).

Thanks for confirming the issue on a non-mac platform. That makes this bug probably dependent on bug 402524.

(and I added 'text-decoration' in the summary).

OS: Mac OS X → All
Hardware: Macintosh → All
Summary: quirks mode: double underline with font-weight: bold, and Arial → quirks mode: double underline (text-decoration) with font-weight: bold, and Arial
This should be marked as WONTFIX.

We don't prefer the text-decoration spec in CSS at quirks mode. The cause is that nsTextFrame draws the underlines per the frames.
Component: GFX: Thebes → Layout: Fonts and Text
QA Contact: thebes → layout.fonts-and-text
Depends on: 403524

Comment 5

6 years ago
Landing bug 403524 merged the standards-mode and quirks-mode text-decoration code, so quirks-mode now complies with that portion of the CSS2.1 spec
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Target Milestone: --- → mozilla8
You need to log in before you can comment on or make changes to this bug.