Closed Bug 403407 Opened 12 years ago Closed 12 years ago

When a file link is clicked the save or open window pops up with OK button grayed out

Categories

(Toolkit :: Downloads API, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 361909

People

(Reporter: johnsond333, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

When some pages I browse to are opened(example included), I can click on a document/file link("New Client Sheet" in example 1st link on right side of page) and the OK button is grayed out.

Reproducible: Always

Steps to Reproduce:
1.Open page
2.Click on first "New Client Sheet" link on right side of page
3.Cannot click on OK button in pop up because it is grayed out
Actual Results:  
I am stuck on the screen, or cancel out of the window.

Expected Results:  
When the link is clicked I should have the option to just click OK when the window pops up.

I have come up with a work around to get the OK button to not be grayed out anymore.

1. when window opens, pull up the drop down and click on other... 
2. when the program selection window opens click on cancel
3. the grayed out OK button is now selectable
I tested this on Windows XP with Firefox 2.0.0.9, and indeed it opens unfocused.
I tested this also on trunk builds but there I don't see this problem. It seems to be 2.0x branch only. Sometimes the size of the page seems to make difference; it did not always happen in a maximized window.
Component: General → Download Manager
QA Contact: general → download.manager
This sounds like bug 361909, which was fixed on the trunk but not branch.

(Alternatively it could be bug 264492, but I think that's less likely.)
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: flock8499
Yeah; verified dup
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.