Closed Bug 403694 Opened 12 years ago Closed 12 years ago

"File -> Work Offline" leaks nsDNSService

Categories

(Core :: Networking, defect, P4)

x86
Windows XP
defect

Tracking

()

RESOLVED DUPLICATE of bug 419562

People

(Reporter: cbook, Assigned: peterv)

References

(Depends on 1 open bug, )

Details

(Keywords: memory-leak)

Attachments

(4 files)

Steps to reproduce:
Start Firefox
Go into offline mode
Leaked!

nsStringStats
 => mAllocCount:          20426
 => mReallocCount:         3165
 => mFreeCount:           20401  --  LEAKED 25 !!!
 => mShareCount:          17591
 => mAdoptCount:           2523
 => mAdoptFreeCount:       2520  --  LEAKED 3 !!!

Will attach leak log
Attached file Leak Log
Attachment #288564 - Attachment mime type: application/octet-stream → text/plain
The leak log looks similar to what I see in bug 102229.  If you have found a consistent way to reproduce bug 102229, you have won.
Summary: File -> Work Offline - Leaks → "File -> Work Offline" leaks nsDNSService
Attached file log from today
jesse, i can reproduce this leak. I have tested the steps to reproduce again and still leak and the log looks like the same as yesterday
Attachment #288694 - Attachment mime type: application/octet-stream → text/plain
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Not sure which way to do the blocking.
Blocks: 102229
Affects tomcats testing so marking a blocker.
Assignee: nobody → jonas
Flags: blocking1.9+
Priority: -- → P4
Attached patch v1Splinter Review
When we go into offline mode nsIOService::SetOffline calls nsSocketTransportService::Shutdown, which will shut down the socket thread. Later, when quitting, we end up calling nsHttpConnectionMgr::Shutdown, which does PostEvent(&nsHttpConnectionMgr::OnMsgShutdown) to do its cleanup. PostEvent tries and fails to post an event to the socket thread and so we skip cleanup.
Assignee: jonas → peterv
Status: NEW → ASSIGNED
I don't know if a testcase is still necessary, but this reproduce the leak for me, consistently.
The testcase uses enhanced privileges, so you need to download it to your computer.
Flags: tracking1.9+ → wanted-next+
peter, do you know if the patch from comment #6 is ready to go ? 
I'm still tracking down an issue with it.
Bent has a better patch in bug 419562.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419562
You need to log in before you can comment on or make changes to this bug.