Closed Bug 403757 Opened 15 years ago Closed 15 years ago

Camino trunk crash on load of adiumextras site

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 403363

People

(Reporter: der.ozean, Unassigned)

References

()

Details

(Keywords: crash)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9b2pre) Gecko/2007111400 Camino/2.0a1pre (like Firefox/3.0b2pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9b2pre) Gecko/2007111400 Camino/2.0a1pre (like Firefox/3.0b2pre)

This issue appeared for me perhaps around the 9th or 10th of November. I do not know if it is related to changes on the page or changes in Camino’s code or changes in both of these. Please refer to the appropriate thread at mozillazine forums, where several people have reproduced the crash with different builds, all of them provide crash logs in pastebin: http://forums.mozillazine.org/viewtopic.php?p=3140980

Reproducible: Sometimes

Steps to Reproduce:
1. Open URL
2. wait while it loads / renders
3. observe crash (if it does not crash, try reloading)
Actual Results:  
Camino crashes

Expected Results:  
no crash

Crash happened on different platforms (intel and PPC)

A few logs:
http://pastebin.mozilla.org/240938 
http://pastebin.mozilla.org/240968
http://pastebin.mozilla.org/242493
I could crash as well (v.2007111323 (2.0a1pre)), so confirming.
The crash happened after going to the 3rd page.

I also crashed Minefield (2007111004 Minefield/3.0b2pre) by reloading the 1st page:
http://crash-stats.mozilla.com/report/index/f69130f3-92b4-11dc-a957-001a4bd46e84?date=2007-11-14-13

Not sure if that is the same crash. If so, this should move to core.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached file crash log
Camino 2007111323 (2.0a1pre), running under Troubleshoot Camino.
I got a completely different stack when I crashed my debug build; it was crashing in zlib and the png decoder.  I'll attach the log when I'm on my other Mac.
Keywords: crash
Here's the log from my debug build from last night.

I crashed the official nightly this morning with a very similar stack (a few different frames in the zlib/MOZ_Z part), but I had to reload the page a couple of times to trigger it there.

Our crash logs are all over the place, though :(
A few stacks for you:
  bp-adcbf71c-92ff-11dc-ba05-001a4bd46e84
  bp-f69130f3-92b4-11dc-a957-001a4bd46e84
  bp-8a2eb11c-92fe-11dc-bb19-001a4bd46e84

Dolske got the following assertion: ###!!! ASSERTION: imgContainer::DrawFrameTo: Invalid aDstRect: '(aDstRect.x >= 0) && (aDstRect.y >= 0) && (aDstRect.x + aDstRect.width <= dstRect.width) && (aDstRect.y + aDstRect.height <= dstRect.height)', file /Users/dolske/ff/ff-trunk3/mozilla/modules/libpr0n/src/imgContainer.cpp, line 1122

Dupe of bug 403363.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403363
I have that assertion in my logs from looking at this crash, too.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.